Add Node to A SQL Server failover Cluster failed with invalid SKU error

After creating a new SQL Server failover cluster node, trying to add the 2nd node to the SQL failover cluster  after entering the product key (same key used for 1st node installation) and hitting next  I’m getting the below error:

The current SKU is invalid.

Solution:

This bug supposed to be fixed by the first Cumulative Update for bug fixes for SQL Server 2008. http://support.microsoft.com/kb/957459/. However, many users are still experiencing this bug.

This problem occurs when you install SQL Server 2008 from a deployment share that uses a custom Defaultsetup.ini file, and this custom file includes the product key for SQL Server 2008.

So the solution is remove defaultsetup.ini from install location. Make sure before deleting the file, write down the product key which is inside the ini file. Then add the node again. When adding the node, you will be asked to enter product key manually.




Related Articles :

  • No Related Articles Found

No comments yet... Be the first to leave a reply!

Software Reviews | Book Reviews | FAQs | Tips | Articles | Performance Tuning | Audit | BI | Clustering | Developer | Reporting | DBA | ASP.NET Ado | Views tips | | Developer FAQs | Replication Tips | OS Tips | Misc Tips | Index Tuning Tips | Hints Tips | High Availability Tips | Hardware Tips | ETL Tips | Components Tips | Configuration Tips | App Dev Tips | OLAP Tips | Admin Tips | Software Reviews | Error | Clustering FAQs | Performance Tuning FAQs | DBA FAQs |