SQL Server Performance

A required privilege is not held by the client

Discussion in 'General DBA Questions' started by stevenchih, Jul 3, 2007.

  1. stevenchih New Member

    I tried to change SQL server 7 service account from "LocalSystem"
    to one of local administrator privilege user account "OperatorSrv"
    through SQL server EM.

    I got this message "A required privilege is not held by the client"

    I know SA had changed SQL agent account under "OperatorSrv" before,
    but I am sure SA is using control panel to change it.

    I recreate "Operatorsrv" local administrator account
    but still same error message.

    Does anyone know how to fix this problem?

    Is it possible SQL agent hold privilege because SA change account through control panel?
    In another words, if I reset SQL agent account back to Localsystem account through SQL server EM, I will be able to change SQL server service account through EM?


    This is only SQL server 7 Prod box left in my customers cabin
    which there is no testing environment available.

    Please help if someone know how to fix it.

    Great thanks
  2. satya Moderator

    If you are using a domain user account to log on to SQL server and for file system access. The user account was created specifically for this application should have necessary policies set on your Active directory structure, and the option “password never expires” should be checked. The specified account must be a local admin and should have correct password to change.

    Satya SKJ
    Microsoft SQL Server MVP
    Writer, Contributing Editor & Moderator
    http://www.SQL-Server-Performance.Com
    This posting is provided AS IS with no rights for the sake of knowledge sharing. Knowledge is of two kinds. We know a subject ourselves or we know where we can find information on it.
  3. stevenchih New Member

    Thanks for your input but it might not be my question.

    I login by using "OperatorSrv" account which is a local administrator account.

    I tried to change SQL server service by using EM but it still gave me

    "A required privilege is not held by the client"

    This is SQL server 7

    How could "password never expires" be in play?
    BTW, OperatorSrv is all have check on "password never expires"

    Let me know if you have more input...I really appreciate.

    Thanks,

Share This Page