SQL Server Performance

Access report by web users

Discussion in 'SQL Server Reporting Services' started by ericyum, Aug 3, 2005.

  1. ericyum New Member

    I have a ASP.NET web application with reporting services. When I deploy the
    application in production, I found some users cannot access the report with
    access denied error. I want to know that how to deploy the reporting
    services to all users?? Does all web users should created the windows
    account in order to use the reporting as I found that the Direcotry Security
    mode of ReportServer virtual directory is set the "Integrated Windows
    Authentication" and the "Anonymous access" is deselected. If I checked the "Anonymous access", the web users also cannot access the report.
    Can I use the impersation in my asp.net web application for accessing the reporting
    services?? I have ever tried that but failed.

    My requirement is user can use the web to access the reporting services.


    Million thanks
  2. ghemant Moderator

    Hi,<br />for that you have to remove "Integrated Windows Authentication" , check "Anonymous Access" , basically Authenticated Access options are used when we need to secure access of site more or less , when "Integrated Windows Authentication " box is checked it ask you for a username ,password and domain (and you have to supply username and password of the machine from where your site are hosted" and have a directory access rights are given), one more thing need to sure / check if machine having NTFS filesystem then you should set "Everyone/Guest" user with "Read" permission in order to get access of the folder (where your site / asp .net files reside).<br /><br /><br />HTH.<br /><br /><br /><br />[<img src='/community/emoticons/emotion-2.gif' alt=':D' />]<br />Regards<br /><br /><br />hsGoswami<br />ghemant@gmail.com<br />"Humans don't have Caliber to PASS TIME , Time it self Pass or Fail Humans" - by Hemant Goswami<br />
  3. ericyum New Member

    I have select the "Anaymous access" and deselect the "Integrated Windows Authentication" in Server and ReportServer virtual directory and set the filesystem to everyone and guest to full permission. However, after doing the action, i tried to access the url,http://ServerName/Reports, the screen shown no error, but no Contents showed. Normally, it would display the uploaded reports and datasets in Content page. In addition, If i tried tohttp://ServerName/ReportServer/, it also showed access denied. If I changed back the setting, it go back to normal. Please help me to solve the problems, thanks...
  4. ghemant Moderator

    <br /><blockquote id="quote"><font size="1" face="Verdana, Arial, Helvetica" id="quote">quote:<hr height="1" noshade id="quote">i tried to access the url,<a target="_blank" href=http://ServerName/Reports>http://ServerName/Reports</a>, the screen shown no error, but no Contents showed. Normally, it would display the uploaded reports and datasets in Content page. In addition, If i tried to<a target="_blank" href=http://ServerName/ReportServer/>http://ServerName/ReportServer/</a>, it also showed access denied.<hr height="1" noshade id="quote"></font id="quote"></blockquote id="quote"><br />normally this should not happened... if you have set the permission proper then<a target="_blank" href=http://servername/reportserver>http://servername/reportserver</a> would show you iis help pages... os would you recheck the settings <br />[<img src='/community/emoticons/emotion-1.gif' alt=':)' />]<br /><br /><br />Regards<br /><br />hsGoswami<br />ghemant@gmail.com<br />"Humans don't have Caliber to PASS TIME , Time it self Pass or Fail Humans" - by Hemant Goswami<br />
  5. tboonleong Member

    I also facing the same problem where it will prompt out the user name and password when user at another pc use webpage to link to report server with url : http:\servername
    eportspagesfolder.aspx

    I try to do the same step as suggested but fail.
    Please help me.
    Thanks a lot.
  6. ghemant Moderator

    Hi,

    quote:
    Hi,
    for that you have to remove "Integrated Windows Authentication" , check "Anonymous Access" , basically Authenticated Access options are used when we need to secure access of site more or less , when "Integrated Windows Authentication " box is checked it ask you for a username ,password and domain (and you have to supply username and password of the machine from where your site are hosted" and have a directory access rights are given), one more thing need to sure / check if machine having NTFS filesystem then you should set "Everyone/Guest" user with "Read" permission in order to get access of the folder (where your site / asp .net files reside).

    this setup works for me ... are you sure the setup / permission set at your end !
    Regards

    hsGoswami
    ghemant@gmail.com
    "Humans don't have Caliber to PASS TIME , Time it self Pass or Fail Humans" - by Hemant Goswami

Share This Page