SQL Server Performance

Accessing Analysis Services through a web page

Discussion in 'Analysis Services/Data Warehousing' started by Irfan Najmi, Jan 28, 2004.

  1. Irfan Najmi New Member

    Hi I have just started using Analysis Services. I have created a cube on a remote server. I am trying to access this cube through a web page but getting an error.<br />The error message says "The pivit table list '''' could not connect to the data source "CUST_PRFT". For information about the data source consult the creator of the file.(0x80004005)"<br /><br />The code behind the webpage is as follows.<br /><br />&lt;html&gt;<br />&lt;script LANGUAGE="VBScript"&gt;<br />&lt;!--<br />Sub Window_OnLoad()<br />LoadControl<br />End Sub<br />Sub LoadControl()<br /><br />On Error Resume Next<br />PivotControl.MemCheck<br />On Error Goto 0<br /><br />PivotControl.ConnectionString = "PROVIDER=MSOLAP;" & _<br /> "DATA SOURCE=KLKYP1C; INITIAL CATALOG=[Customer Profitability]"<br />PivotControl.DataMember = "CUST_PRFT"<br /><br />Set view = PivotControl.ActiveView<br /><br />view.ColumnAxis.InsertFieldSet view.FieldSets("YR_MON")<br />view.RowAxis.InsertFieldSet view.FieldSets("RXDA")<br />view.ColumnAxis.DisplayEmptyMembers = 0<br />view.RowAxis.DisplayEmptyMembers = 0<br />view.DataAxis.InsertTotal view.Totals("Tot Sls Amt")<br /><br />for each ttl in view.dataaxis.totals<br />ttl.numberformat = "Standard"<br />next<br /><br /><br />On Error Resume Next<br />PivotControl.MemCheck<br />On Error Goto 0<br /><br /><br /><br />End Sub<br />//--&gt;<br />&lt;/script&gt;<br /><br /><br />&lt;head&gt;<br />&lt;title&gt;&lt;/title&gt;<br />&lt;/head&gt;<br /><br />&lt;body&gt;<br /><br />&lt;h2 align="center"&gt;&lt;font color="#000080"&gt;&lt;b&gt;&lt;i&gt;Customer Profitability&nbsp; &lt;/i&gt;&lt;/b&gt;&lt;/font&gt;&nbsp;&nbsp;<br />&lt;/h2&gt;<br /><br />&lt<img src='/community/emoticons/emotion-4.gif' alt=';p' />&gt;<br />&lt;object classid="clsid:0002E520-0000-0000-C000-000000000046" id="PivotControl"<br />codebase="file://carw1001/wwwroot/owc/msowc.cab"<br />style="HEIGHT: 384px; LEFT: 10px; TOP: 60px; WIDTH: 551px" width="518" height="384"&gt;<br />&lt;/object&gt;<br />&lt;/p&gt;<br />&lt;/body&gt;<br />&lt;/html&gt;<br /><br />Please advice.<br /><br /><br /><br />Irfan Najmi
  2. vbkenya New Member

    Possible issues:

    -I think security could be an issue here. You need to have read privileges on the cube that you are trying to access.

    -Check your MDAC version (as far As I know, you need a compatible version of the Pivot Table Services)


    Nathan H.O.
    Moderator
    SQL-Server-Performance.com
  3. Irfan Najmi New Member

    I installed MDAC 2.8 from Microsoft web site. It didn#%92t solve the issue. Please help.

    Irfan Najmi
  4. Irfan Najmi New Member

    Also when I try to register the remote server from Analysis Manager, I get this error

    "Cannot open connection to Analysis server 'Server Name' Error in data [Possible data corruption]."

    I know there is no data corruption on the server because the cube runs fine on the server.

    Irfan Najmi
  5. Irfan Najmi New Member

    I found an article on www.sqlmag.com that solved the problem. Now I can access the cube from the web. The name of the article is "Analysis Services Security and HTTP". The article id is 40909.<br /><br />[<img src='/community/emoticons/emotion-2.gif' alt=':D' />]<br /><br />Irfan Najmi

Share This Page