SQL Server Performance

Agent Security doesn't appear in Transaction Replication

Discussion in 'SQL Server 2005 Replication' started by Red Devilic, Jul 20, 2009.

  1. Red Devilic New Member

    Sorry if my English isn't good
    I have 2 servers
    Server A - SQL Server 2000 SP4 Enterprise Edition
    Server B - SQL Server 2005 SP3 Enterprise Edition
    Server A : Publisher + Local Distrbutor
    Server B : Subcriber
    When I set up Transaction Replication, it works. But after 2 weeks, when I reinstall, it has error.
    At Creating Publication Step, after "Specify when to run the Snapshot Agent", it goes to Finished Step."Agent Security" Step doesn't appear.
    So I can't configure username and password to connect to Subcriber.Finally, when I start replicating, it doesn't work.
    Error is " Login failed for user 'NT AUTHORITYANONYMOUS LOGON'. Cannnot connect to Subcribers."
    How can I fix that ? It worked, but now it doesn't. There must be someone's changed something but I don't know what has been changed ?
    Thanks for helping
  2. ghemant Moderator

    Hi,Welcome to the forums!!I would suggest to go through the link http://social.msdn.microsoft.com/forums/en-US/sqlreplication/thread/9fb79ff5-6352-467a-b9dc-eeafb5bbe8d4/
  3. Red Devilic New Member

    Thanks for reply.
    I've read the link you show. His problem 's different with mine.
    The error we got are the same. But in his situation, he had alias in Publisher itself. I didn't have.
    In my situation , the Agent Security step doesn't appear. So when Publisher connected to the Subcribers, I wonder which account Publisher used ?
    Seem someone configured the agent process run under Windows authentication ? If so, what I have to do ?
    I setup Replication between Server C and B, it worked, but C with A it failed. Seem the problem's in the server A.
    Thanks for reply

Share This Page