SQL Server Performance

AWE and Lock Memory

Discussion in 'Performance Tuning for Hardware Configurations' started by tpeterson, Jul 11, 2006.

  1. tpeterson New Member

    I am running SQL server 2000 Enterprise Edition on MS Sever 2003 Enterprise
    Edition.

    I have enabled AWE on the SQL server. I have added the user account that SQL runs under to the Lock Pages in Memory right under the Group policy editor.

    I have the /3GB and /PAE extensions in my boot.ini file and I get an error
    "Cannot use Address Windowing Extensions because lock memory privilege was
    not granted."

    I am on an NT4 domain, is this why the lock memory privilege cannot be
    granted?
  2. joechang New Member

    have no idea,
    i would try switching the sql server to a local account with this right
    i don't normally deal with user admin issues
  3. satya Moderator

    You need to grant 'lock pages in memory' privilege for the SQL server service account on the server.

    Satya SKJ
    Microsoft SQL Server MVP
    Contributing Editor & Forums Moderator
    http://www.SQL-Server-Performance.Com
    This posting is provided �AS IS� with no rights for the sake of knowledge sharing.
  4. tpeterson New Member

    I am running SQL under the domain admin account and that is the one I granted the lock privileges to. Actually, I got so fustrated I put Everyone in the Lock Pages privilege.

    Joechang, I don't think I can use your recommendation of running SQL under a local account as it would prevent some network access to the SQL server...no?
  5. joechang New Member

    this is just a test to verify that the lock pages will work,
    otherwise, you have some other problem
    possibly the edition was recorded incorrectly
  6. tpeterson New Member

    I ran SQL under the local system account and gave that account lock privilege and it still does not enable. I get the same error message in my SQL logs.
  7. joechang New Member

    how much memory is in your system?

    lookin your SQL Server MSSQLLog directory for the file ERRORLOG
    paste the contents into here, some thing is not right with your system

Share This Page