SQL Server Performance

AWE is not getting enabled.

Discussion in 'SQL Server 2005 General DBA Questions' started by najeed_dba, Aug 15, 2007.

  1. najeed_dba New Member

    Hi all ,
    Need some help...
    We enabled /3GB Switch from boot.ini file,and then reboooted the server and then I try to enable from SQL Server
    Sp_configure ‘awe enable’,1
    Go
    Reconfigure
    But, then we got the error saying that,
    Configuration option 'awe enabled' changed from 0 to 1. Run the RECONFIGURE statement to install.
    Msg 5845, Level 16, State 1, Line 1
    Address Windowing Extensions (AWE) requires the 'lock pages in memory' privilege which is not currently present in the access token of the process.
    Then , our win admin gave the sql service account the above mentioned privilege (i.e.) lock pages in memory.
    Link:

    Then again I try to enable it got the following error.
    Configuration option 'awe enabled' changed from 1to 1. Run the RECONFIGURE statement to install.
    Msg 5845, Level 16, State 1, Line 1
    Address Windowing Extensions (AWE) requires the 'lock pages in memory' privilege which is not currently present in the access token of the process
    When I run sp_configure, I see in "awe enabled" row output as - - - 0,1,1,0 ( run value = 0).
    This run value =0,( right most value from the output of sp_configure) means that AWE is not enabled. Is it..
    But when i go to the instance ---> Right click ---> Properties ---> memory ---> Here , i can see the option "Awe Enabled" checked, but as we can see that from sp_configure, run value for "awe enabled' is 0.
    Any thoughts regarding this.
    Configuration:
    SQL Server 2005 Standard Edition SP1,
    Win 2003 Standard Edition SP1,
    3926MB Memory ( 4GB).
    Thanks.
    //N
  2. ghemant Moderator

  3. satya Moderator

    Refer to the article about how to grant this privilege the sql server service account please refer to the MSDN article ‘How to: Enable the Lock Pages in Memory Option (Windows)’. Restarting the machine typically helps permissions granted to the sql server service account take effect.
    On 32 bit machines, if AWE Allocated is 0 in the data from dbcc memory status and the sp_configure option 'awe enabled' is set to 1, then lock pages in memory privilege has not been granted to the service account or it has not taken effect.
  4. najeed_dba New Member

    I rebooted the server , now i am not getting that error about the permission regarding the SQL Server service account.
    But, when i run the sp_configure command, the run_value is still showing as 0.
    Can someone tell ,do i need to do anything elso too.
    Hoping for qucik respone.
    Thanks for helping.
    //N
  5. ghemant Moderator

    Have you refer and followed the link as suggested.
  6. satya Moderator

    Check the permission for the SQL Server service account, also as suggested go thru the article about the privileges to that account needed in this regad.

Share This Page