SQL Server Performance

AWE not working.....user rights???

Discussion in 'Performance Tuning for Hardware Configurations' started by purdaddy, Nov 21, 2006.

  1. purdaddy New Member

    Hey guys (and gals),

    We've got a lot of SQL 2000 Ent. Ed. servers configured for and running AWE successfully, but today we were asked to make another SQL 2000 EE server AWE enabled.

    So, as we did the previous configurations, I performed the following steps:

    1) Installed SQL SP4 Hotfix for AWE (already had SP4 installed)
    2) Using gpedit.msc, granted "Lock Pages in Memory" for the domain acct that runs SQLServer.exe; then ran the GPUPDATE /FORCE (this is a Windows 2003 Ent Server)
    3) Bounced Server
    4) Using Query Analyzer, ran sp_configure to enable AWE and to set min and max server memory to 8Gb (15.8Gb available on this box)
    5) Bounced Server
    5) Restarted SQL Server over and over

    And when it didn't work, I retried every one of those steps, and then in different orders, and going over and over and over all the settings, I'm at my wits end.

    The only thing I see in the SQL Server Error Log each time I restart SQL is "Cannot use Address Windowing Extensions because lock memory privilege was not granted." and "Warning: unable to allocate 'min server memory' of 8096MB."

    Again, the domain account that has the "Lock Pages in Memory" privilege also runs the SQL Server service on all the other servers, which were (at least as far as I can tell/remember) configured the same way. But it doesn't work on this one.

    Has anyone ever seen this before?

    Thanks,

    -Patrick
  2. catullus Member

    Maybe a dumb question, but did you specify /PAE in the boot.ini?
  3. purdaddy New Member

    quote:Originally posted by catullus

    Maybe a dumb question, but did you specify /PAE in the boot.ini?

    Good point, but yes, that's a standard for all our Windows 2003 Servers here. Thanks for the reply though.

    -Patrick
  4. satya Moderator

  5. MohammedU New Member

    Once again check the permissions of the account, I believe account should have DOMAIN admin prevelages along with local admin.

    Mohammed.
  6. purdaddy New Member

    quote:Originally posted by satya

    KBAhttp://support.microsoft.com/default.aspx?scid=kb;en-us;274750 link fyi, just check the steps.

    Yeah, I've got that article printed out and it's been on my desk for some time. It was a reference, along with a five or six other KBA's, for all the servers I enabled AWE on.

    We've actually got an issue open with Microsoft at this point, so I'll post back here what we find. Sounds like we're looking at some type of AD policy or permissions problem, but have not found a resolution yet. Maybe I've missed something, but I've gone over and thru all of the steps to enable AWE on this one box like 15 times now to no avail....

    Thanks again for your reply!

    -Patrick
  7. purdaddy New Member

    quote:Originally posted by MohammedU

    Once again check the permissions of the account, I believe account should have DOMAIN admin prevelages along with local admin.

    Mohammed.

    Another good point. We'll look into it, but.....this is the same domain account we use on all of the other production SQL boxes as the service account and they all work. Doesn't seem like it should work on each of those and not on this one. All servers are members of the same domain, along with the account being a member of that same domain. The SQL services start up just fine. Just no AWE.

    Thanks,

    -Patrick
  8. satya Moderator

    Regardless, this user has ADMIN privileges on Domain and local still it requires the permissions under the DOMAIN
    policies, not the local policies.

    Satya SKJ
    Microsoft SQL Server MVP
    Contributing Editor & Forums Moderator
    http://www.SQL-Server-Performance.Com
    This posting is provided AS IS with no rights for the sake of knowledge sharing.
  9. MohammedU New Member

    What is yoru build number??

    Only I can think of something wrong with SP4 hotfix installation.
    Try reinstalling hotfix.

    Mohammed U.
  10. purdaddy New Member

    Just for posterity and to prove I'm human, I'll post the outcome.......

    Turned out to be that this particular server was a Standard Edition and because we've got 108 SQL Servers here I overlooked it somehow.

    Thanks for all the good advice. It was just plain old overlooking the obvious and missing the most basic requirement thinking it had to be complicated for it not to be working correctly.....
  11. MohammedU New Member

    LOL<img src='/community/emoticons/emotion-1.gif' alt=':)' /><br /><br />Mohammed U.

Share This Page