SQL Server Performance

AWE - setting /pae and /3gb

Discussion in 'SQL Server 2005 General DBA Questions' started by Trev256b, May 24, 2011.

  1. Trev256b Member

    If you set /pae (to use >4GB) do you first have to set /3gb?
  2. Luis Martin Moderator

  3. Jahanzaib Member

    What is your OS version , is it 32-bit or 64-bit,no need of PAE switch in 64-Bit
  4. Trev256b Member

    luis - thanks at least i know i don't need to the lower switch first. referring to my other thread - any idea why setting 'lock poages to memory' without setting AWE might have memory issues? is it as simple as too many pages in memory will mean less available for OS or other apps?

    syed - 32bit
  5. Jahanzaib Member

    You must enable AWE in 32-bit version with lock pages other wise extension will not occur in memory
  6. Trev256b Member

    ok - so the term 'lock pages in memory' actually means 'allow memory to be used'. thanks
  7. satya Moderator

    I believe you need to take your time to read the Books Online, see this is what expalined in BOL:
    This policy determines which accounts can use a process to keep data in physical memory, preventing the system from paging the data to virtual memory on disk. The Lock Pages in Memory option is set to OFF by default in SQL Server. If you have system administrator permissions, you can enable the option manually by using the Windows Group Policy tool (gpedit.msc) and assign this permission to the account that SQL Server is running.
    For more information about how to enable the Lock Pages in Memory option, see How to: Enable the Lock Pages in Memory Option (Windows).

Share This Page