SQL Server Performance

Broken Images in Reports

Discussion in 'SQL Server Reporting Services' started by chaitanya, Jun 30, 2007.

  1. chaitanya New Member

    Hi,



    I have a report that works fine when i deploy it in the development environment, but when i deploy the same report on the production server pointing to the same data source as the development environment; the images doesn't show up. I do see broken image X on all the images.



    I searched the internet but couldn't find a solution to solve this problem. Any help on this will be appreciated.



    Thanks,

    Chaitanya

  2. satya Moderator

    Check the path, data source, permission for the user deploying this report on the specified path etc. including the service pack levels on SQL & WIndows.

    Satya SKJ
    Microsoft SQL Server MVP
    Writer, Contributing Editor & Moderator
    http://www.SQL-Server-Performance.Com
    This posting is provided AS IS with no rights for the sake of knowledge sharing. Knowledge is of two kinds. We know a subject ourselves or we know where we can find information on it.
  3. dineshasanka Moderator

    what is the image type you have used. If you have used emmbadded, it is with report so you don't have to worry if not you have to transer your images as well

    ----------------------------------------
    Contributing Editor, Writer & Forums Moderator
    http://www.SQL-Server-Performance.Com

    Visit my Blog at
    http://dineshasanka.spaces.live.com/
  4. chaitanya New Member

    The problem has been resolved.

    When i am investigating the security setting and other configuration files for the reporting services i realised that i have not applied SP2 for the Reporting Services on the Production Server. SP2 provided a lot of updates which include showing the Print button on the Report Viewer, displaying images etc which are helpful.

    By the way the images are web based external URL. I appreciate your help.


    Thanks,
    Chaitanya

  5. satya Moderator

    [<img src='/community/emoticons/emotion-1.gif' alt=':)' />] Appreciate your feedback, that helps others with similar problem.<br />Additionally I suggest to read SP2 as well about the changes involved in Reporting Services, as you are extracting/placing images from a web based URL.<br /><br /><b>Satya SKJ</b><br />Microsoft SQL Server MVP<br />Writer, Contributing Editor & Moderator<br /<a target="_blank" href=http://www.SQL-Server-Performance.Com>http://www.SQL-Server-Performance.Com</a><br /><center><font color="teal"><font size="1">This posting is provided AS IS with no rights for the sake of <i>knowledge sharing. <hr noshade size="1">Knowledge is of two kinds. We know a subject ourselves or we know where we can find information on it.</i></font id="size1"></font id="teal"></center>

Share This Page