SQL Server Performance

can i disable ms search?

Discussion in 'General DBA Questions' started by NewDBA, Jun 18, 2004.

  1. NewDBA Member

    the collect procedure for the msscntrs.dll service...generated and error.

    I am getting this error on my sql 2000 sp3 server.
    Looks like this error is corrupted full text index. service?

    I checked the server: there is no full text catalog defined.
    Can i disable Microsoft search service without harm SQL?
  2. Luis Martin Moderator

    Yes, if your app don't use full text you can disable without problem.


    Luis Martin
    Moderator
    SQL-Server-Performance.com

    All postings are provided “AS IS” with no warranties for accuracy.

  3. NewDBA Member

    thank you
  4. NewDBA Member

    I disabled MsSearch but still getting this error every minute
    "The Collect Procedure for the "MSSCNTRS" service in DLL "C:pROGRA~1COMMON~1SystemMSSearchBinmsscntrs.dll" generated an exception or returned an invalid status. Performance data returned by counter DLL will be not be returned in Perf Data Block. Exception or status code returned is data DWORD 0. "

    Could someone help?
  5. Luis Martin Moderator

  6. satya Moderator

    Try to register the specified .DLL on the server using REGSVR32 utility.
    If possible reboot the box for refresh of registry.

    Satya SKJ
    Moderator
    http://www.SQL-Server-Performance.Com/forum
    This posting is provided “AS IS” with no rights for the sake of knowledge sharing.
  7. NewDBA Member

    Yes I read this but I think my problem is perf.counters...<br />So instead of unistalling mssearch i added a value "Disable Performance Counters"=1<br />to registry:<br /><br />Localmashine-&gt;system -&gt;currentcontrolset-&gt;services-&gt;MSSEARCh-&gt<img src='/community/emoticons/emotion-4.gif' alt=';p' />erformance.<br /><br />I still getting an error.Should I restart server after that counter added?
  8. Argyle New Member

    It happens with most services you disable that have performance counters. Try setting it to manual instead. Or use the registry key you entered, might require a restart.

Share This Page