SQL Server Performance

Cannot launch maintenance plan GUI

Discussion in 'SQL Server 2005 General DBA Questions' started by acki4711, Jan 23, 2008.

  1. acki4711 Member

    Hi all,
    Just installed sql server ent. x64 with sp2 and tried to create a new maintenance plan.
    Error dialog showing up telling me to install sql management tools first??
    (I have installed client components including management tools but excludet business int. dev., sw dev. kit and sqlxml client features
    I have set up a dozent sql server x32 & x64 the same way and had never problems like this ?? )
    Tried to sucessfully reaply sp2 -> no effect.
    Any help is highly appreciated !
    TIA
    acki
  2. satya Moderator

    Try to install SQl 2005 Management tools again on this machine alongwith SP2, it seems they are not looking good to open up the GUI.
  3. acki4711 Member

    - removed entire installation
    - rebootet
    - reinstalled server + client components (exludes as above)
    - sp2
    - rebootet
    -> same result cannot open maintenance gui
    ==================================
    The action you attempted to perform on a remote instance of SQL Server has failed because the action requires a SQL Server component that is not installed on the remote computer. To proceed, install SQL Server 2005 Management Tools on the remote computer, and then try again. For more information, see "How to: Install SQL Server 2005 (Setup)" in SQL Server 2005 Books Online, or find the article on MSDN at http://go.microsoft.com/fwlink/?LinkID=57083 . (ObjectExplorer)
    ------------------------------
    For help, click: http://go.microsoft.com/fwlink/?LinkID=57083
    ------------------------------
    Program Location:
    at Microsoft.SqlServer.Management.DatabaseMaintenance.MaintDesignerMenuHandler.Invoke()

  4. satya Moderator

    Do you have SSIS installed on that remote server?
    you do need to have SSIS installed to get all the right components to Maintance plans working.
  5. acki4711 Member

    satya,
    No SSIS is installed and for simple backup maintenance plans you don't have to install SSIS.
    All my other setups never have SSIS installed and there maintenance plans are all running well?
    I just can't figure out what's going wrong here...
  6. acki4711 Member

    OK, found out it has somthing to do with sql service accout permissions.
    If service account is local sysadmin on the machine all works fine, if not error as mentioned above.
    has any1 a clue which permissions I need to modify? (Running sql service account as local admin is not a option (security)) ?
    TIA
    acki
  7. satya Moderator

    This is peculiar, I haven't had such problem even though it is not a sysadmin.
    Any reason why a SQL service account need not be a local admin on the serve?
    Is it like this on all other servers?
    What is difference between the operating system, service pack level between this server and other server with similar configuration>?
  8. jasmit23 New Member

    File Permissions... if you are using a local user mannke sure that theis user has the appropriate SQL folders

Share This Page