SQL Server Performance

Cannot open DTS/SSIS package on Cluster...

Discussion in 'SQL Server 2005 Integration Services' started by sql_jr, May 15, 2008.

  1. sql_jr New Member

    hi, I get an error on one node when I try to connect to the sql server and drill down to the jobs for the dts legacy packages (Other node works fine!)
    Creating an instance of COM component with CLSID...............from the IClassfactory.....Microsoft.Managed.DTS
    Any ideas how to resolve? We're on SP2..3042 HELP!
  2. MohammedU New Member

    It could be .net installation issue...
    Did you try reinstalling the DTS component? If not try it...
  3. sql_jr New Member

    Thx for reply. You mean the SSIS?
    This also happens to be a 2000DTS package so wonder if the "legacy" components is an issue too?
    Any ideas? THX AGAIN!
  4. sql_jr New Member

    OK! I solved the first issue, and eliminated the error by registering the SQLTaskConnections.dll.
    However, no I can look at the job w/o the error, but the job info and detail is NOT loaded. It is blank. I tried recreating the job and same thing!
    FUNNY thing is, when I connect to sql from the other node, I see EVERYTHING. Thoughts? THX.
  5. LindaJ New Member

    Were the legacy components installed on both nodes? They need to be because they are not cluster aware.
  6. Malcatrazz New Member

    According to:
    http://msdn.microsoft.com/en-us/library/ms345193.aspx
    “The Integration Services service is not a clustered or cluster-aware service, and does not support failover from one cluster node to another. Therefore, in a clustered environment, Integration Services should be installed and started as a stand-alone service on each node in the cluster.”
    It then goes on to explain how to configure SSIS as a cluster resource (which is not recommended).
    Hope this helps...

Share This Page