SQL Server Performance

Cannot use KILL to kill your own process

Discussion in 'General DBA Questions' started by gk_sql, Sep 12, 2006.

  1. gk_sql New Member

    Hi,

    I am getting run time errors in application. The error is

    "Cannot use KILL to kill your own process."

    I used dbcc input buffer to monitor the queries. the process itself is locking some tables. I tried to kill dbcc input buffer process in that i got the above error.

    We are on production.

    A quick reply is appreciated. [?]

    GK
  2. Chappy New Member

    Log in again on a different sa connection
  3. satya Moderator

    IT sounds like a major issues with blocking in this case when you're trying to kill the connection.

    Satya SKJ
    Microsoft SQL Server MVP
    Contributing Editor & Forums Moderator
    http://www.SQL-Server-Performance.Com
    This posting is provided AS IS with no rights for the sake of knowledge sharing.
  4. ramkumar.mu New Member

    Try opening a new window and run kill(spid of inputbuffer command)

    quote:Originally posted by gk_sql

    Hi,

    I am getting run time errors in application. The error is

    "Cannot use KILL to kill your own process."

    I used dbcc input buffer to monitor the queries. the process itself is locking some tables. I tried to kill dbcc input buffer process in that i got the above error.

    We are on production.

    A quick reply is appreciated. [?]

    GK

    Thanks,
    Ram

    "It is easy to write code for a spec and walk in water, provided, both are freezed..."
  5. k_ashish2002 New Member

    If its simple select statement then try this syntax
    select ..........(column name) from .... (table name) option maxdop(1).



    Ashish
  6. dcione New Member

    Ok got same error so if someone else get this error here is it
    i was trying killing spid on aaa database
    then i saw this error, but in smss the selected database was the aaa, so i changed to master database and tried again , and it works
    use master
    kill 56
    then . try change your database to another one and try again.
  7. Sandy New Member

    Cione,
    I agree with you.
    Thanks,
    Sandy

Share This Page