SQL Server Performance

Can't change file copy and restore settings on Secondary databases in logshipping

Discussion in 'SQL Server 2008 Log Shipping' started by WingSzeto, Feb 20, 2009.

  1. WingSzeto Member

    After setting up the logshipping and working, I tried to go back to the secondary databases logshipping settings to change the restore delay time from 15 minutes to 1 day, when I clicked the '....' button next to the database name on the 'Transaction Log Shipping' properties window, it gave me an error as follows:
    "An Exception occured while executing a Transact-SQL statement or batch. (SqlMangerUI)
    Addtitional Information:
    Only memebers of the sysadmin fixed server role can perform this operation. (Microsoft SQL server, Error: 21089)"
    I registered the SQL server in SQL Management studio under sa and when I set up the secondary database settings for the logshipping, I connected the secondary server instance with a SQL login which has the sysadmin fixed server role. I am puzzled as why it keeps saying I don't have the sysadmin right. If I tried to disable the logshipping by unchecking the box of 'Enable this as a primary database in a log shipping configuration' so I could start over, but it said the SQL mgmt studio could not delete Log Shipping Configuration and gave me the same needing the sysadmin fixed role message.
    I am puzzled and any help on this is very much appreciated.
    By the way, we are using SQL 2008 64 bits on Windows 2008 64 bits and in a two node active-passive cluster envir.
    wingman
  2. preethi Member

    First of all, I need to admit that I have not seen this error before. But I have seen wired wrrors popping up, at different times, if the database is not having a proper owner. Can you check whether the database is having an owner?
  3. WingSzeto Member

    The owner of the db is sa.
    Yes, I am aware of the database owner situation. When we moved our databases from SQL 2005 to SQL 2008, we encountered some database owner issue, which made the repliation generating error messages and stopped working.
  4. WingSzeto Member

    If I want to report this as a bug, how should I do that?

Share This Page