SQL Server Performance

Creating Plans gives Exception from HRESULT: 0xC0010014 (Microsoft.SqlServer.DTSRuntimeWrap)

Discussion in 'SQL Server 2005 Clustering' started by techbabu303, Dec 17, 2007.

  1. techbabu303 New Member

    have an issue with the SQL Server deployment on a Cluster.

    Environment:

    Microsoft Windows 2003 R2 x64 Cluster
    Microsoft SQL Server 2005 SP 2 x64

    Issue:
    SQL Server 2005 is deployed on virtual server which is connected to 2
    nodes, everything works fine with respect to the application databases
    but when we try to setup a maintenance plan I get an error (find
    attached in previous email).

    Going through a few microsoft forums and SQL Server formus it
    suggested me to apply a hotfix(3159) that is available for SP 2, I
    installed that hotfix but I still get the same error.

    One other website says that this issue is because SQL Server is
    installed in Program files (x86) directory, and if I install it on the
    Program Files directory it would work (
    http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=609326&SiteID=1
    ). I am not sure how true is this.

    Also reffered earlier post in forum and planned to test with integration service as local account but not sure if this will impact the
    cluster .
    Cheers
    Sat
  2. techbabu303 New Member

    Some more details ................
    The account currently used is for SSIS services is default
    NT AUTHORITYNetworkService
    is this right account ?
    This same account used before installing sp2 and this was working before installing SP2
    Regards
    sat
  3. satya Moderator

    Have you captured any SYSMON counters for CPU & Memory in this regard?
    Why not use a local/domain account for the SSIS service, there are number of changes happened as compared to SP2 and pre-sp2 configuration of SQL engine. I would suggest to test the same on your development environment and open a ticket with PSS for this error.
  4. ravirxz New Member

    Hi,
    Yes I tried to capture any instances on the sysmon but could not find any. I am not sure how would changing it to a local account would work? as this is on a cluster as of now. But just an FYI i did try the same with a domain account with no luck.
    Please do suggest me if you have any other suggestions for the same.
    Thanks,
    Ravi
  5. techbabu303 New Member

    Hi Staya,
    Forgot to mention that is my buddy Ravi working on deployment handling this issue....
    On the types of service accounts I was doing some additional read up on SQL central , the recommendations were to use different domain accounts for each SQL service to tighten security I guess.
    But this does not suffice our original query could this be bug ?
    Has anyone reported this before , according to threads in msdn forums this was observed after installing SP1 and hot fix was provided, this must have been included in SP2 so should have been resolved right ?
    Cheers
    Sat
  6. satya Moderator

    Service Pack should be resolving the bugs reported, but some of them may be specific to an environment where you need to raise a support ticket to get such fixes, so in this case I suggest teh same to contact MS PSS.
  7. techbabu303 New Member

    Thank you....
    [:)]
    Sat

Share This Page