SQL Server Performance

Cube cloning problem

Discussion in 'Analysis Services/Data Warehousing' started by progressive, Oct 15, 2003.

  1. progressive New Member


    I have a cube which I have to clone using DSO objects in VB .NET. I managed to do this by using the Clone method and changing the name of the fact table from "TEMPLATE" to "FactNew" in the From and Join Clauses and also the SourceTable property. The new cube looks fine when opened in the Analysis Manager for Editing. But it fails to process. The message I get is
    Error(-2147221425): The object structure is not valid (A table was detected in the schema that is not joined to any other table); Time:10/15/2003 7:45:45 PM

    I am clueless about which table is causing the problem.
    The log file of Analysis Services is also not very helpful:
    10/15/2003 7:45:45 PM12783Initiating transaction in Database 'ZOOM'
    10/15/2003 7:45:45 PM12783 Processing Cube 'ZOOM' Start time: 7:45:45 PM
    10/15/2003 7:45:45 PM12783 Error(-2147221425): The object structure is not valid (A table was detected in the schema that is not joined to any other table); Time:10/15/2003 7:45:45 PM
    10/15/2003 7:45:45 PM12783 Processing Cube 'ZOOM' failed. No changes have been made to the database.
    10/15/2003 7:45:45 PM12783 Rolling back transaction in Database 'ZOOM'


    When I change the fact table of this new cube to "TEMPLATE", the same as of the original cube, this same cube process without problems. Now if I change the fact table to "FactNew" again, it still processes correctly.

    Can someone suggest a solution so that I do not have to perform this workaround and do the cloning only programmatically?

    -Yash
  2. satya Moderator

    WHat is the level of service pack for SQL & OLAP?

    _________
    Satya SKJ
    Moderator
    SQL-Server-Performance.Com

Share This Page