SQL Server Performance

data source problem in ssrs 2008 r2

Discussion in 'ALL SQL SERVER QUESTIONS' started by jassiedog, May 14, 2012.

  1. jassiedog New Member

    I am having a data source problem on a report builder 3.0 report that I am setting up. I am using a custom data source that is not shared with any other applications.
    For the connections to work, I can get the 'credentials stored securely in the report server' to work. However I would prefer for the 'windows entegrated security' option to work.
    Note: This option only started to work once I changed the owner of the database from myself to a 'sql login' that I just created. The sql login that I just created is in the security section only for the database instance. This sql login is not in the security are for the new database that I just created called 'testdb'.
    Thus can you tell me what I need to do make the 'windows integrated security to work?
  2. Shehap MVP, MCTS, MCITP SQL Server

    For legibility , Integrated security here of Data source model should have nothing to do with db_owner privileges , but it depends on the credential you view with report since it if it has basically t Read +Exec Stored procedures on TestDB , it will go fine ..

    Hence, once you changed db_owner from your own credential to another SQL login , you have lost all access to this DB that you can' view relevant report , thereby you have to check basically the privileges stated above .

    Please let me know if any further help needed

Share This Page