SQL Server Performance

DBCC SHOWCONTIG results show an unexisting index

Discussion in 'General DBA Questions' started by viv, Aug 11, 2009.

  1. viv New Member

    Hi Everyone

    During my routine checks on our production server i ran following dbcc command on one of the database tables.

    The result of the above command writes three records. Two of this records are for legitimate indexes but the thrid index named ''ttblCompany' doesn't seem to exist when i look under table->indexes node in object explorer.

    I have tried running dbcc indexdefrag on this index with following command but that results with an error (see below)

    RESULT:
    Msg 2560, Level 16, State 1, Line 1
    Parameter 3 is incorrect for this DBCC statement.

    Can anyone think a reason why this third index exists on the table?

    Thanks a lot in advance.

    Vivek
  2. techbabu303 New Member

    Check the DDF table sysindexes by querying the system table for this index.
    -Sat
  3. viv New Member

    I have tried that and there is definately a record for this idnex and its been used 113 times as well.
    I have found couple of indexes like this and they all have one thing in common which is they all have indid=255???
    does that mean its a system/internal index or something????
  4. viv New Member

    any more ideas guys?
  5. cstrong New Member

    Indid 255 is text, ntext or image data. Do you have any of these types within your table?

Share This Page