SQL Server Performance

Do I Need to Enable AWE?

Discussion in 'SQL Server 2005 Performance Tuning for Hardware' started by jbates99, Oct 23, 2008.

  1. jbates99 Member

    Hi all,

    These are the specs:
    Windows 2003 Enterprise SP1
    SQL Server 2005 Standard SP2

    24 GB memory
    SQL Server is configured to allocate memory dynamically.

    The performance counters I have ran do NOT indicate a memory bottleneck.

    However, a consultant has recommended that we make the following changes "to enable SQL Server 2005 Standard to be able to use > 3GB of memory if needed."

    I thought it was not necessary to enable AWE if the OS is 2003 Enterprise.

    Please review his suggestions (below) and reply back.

    Thanks very much. John
    Recommendation: This server has 24GB of memory available. In order for
    SQL to access above the 3GB you need to enable AWE for the SQL server
    Also Enable the Lock Pages in Memory Option – this is required to be able to
    enable AWE on the SQL server. This is done through group policy for either the
    local machine or group policy on an Organization Unit the server resides
    within.
  2. Saurabh Srivastava New Member

    Yes you need to enable AWE and Lock pages in memory if you are using 32-bit platform. On 64-bit you just have to enable lock pacges in memory.
    As you are using SQL Server 2005 standard edition so I have a suspicion about Lock pages in memory. I have heard that it is not available in SQL Server 2005 standard edition. Albeit, I am not sure as I read in several blogs and articles on different websites. I remember somene on this website mentioning that he had to enable it manually for SQL Server 2005 standrad edition and it worked for him. May be, people on diffrent blogs trying to say that it is not enable by default for SQL Server standard edition and need to do it manually. I have'nt seen this on Microsoft website or whitepaper saying Lock pages in memory is not for SQL Server standard edition.
  3. Saurabh Srivastava New Member

    Set aside some memory for OS. Don't allocate all 28GB to SQL Server.
  4. jbates99 Member

    Thanks Saurabh. Other post I've read also indicate there is differing opinions on "locking pages in memory". I will experiment.

    Thanks, John
  5. Saurabh Srivastava New Member

    If you have Microsoft support call and ask them. If I get to know this information I will post it here for you.
  6. Saurabh Srivastava New Member

Share This Page