SQL Server Performance

Enabling AWE - PAE - /3GB

Discussion in 'Performance Tuning for Hardware Configurations' started by angelo_theus, Jan 24, 2008.

  1. angelo_theus New Member

    Hi Master,
    I want to know if my step is right or not for enabling AWE. I open boot.ini file and add like this one :
    (I'm using Windows Server 2003 Enterprise and SQL 2000 Enterprise - My System memory is 6GB)
    Step 1 : open boot.ini file and modify :
    [boot loader]
    timeout=30
    default=multi(0)disk(0)rdisk(0)partition(1)WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Windows Server 2003, Enterprise" /fastdetect /NoExecute=OptOut /PAE /3GB
    close and save boot.ini file......
    Step 2 :
    and Enable SQL AWE using Query Analyzer like this one :

    sp_configure 'show advanced option' ,1
    reconfigure
    go
    sp_configure 'awe enabled' ,1
    reconfigure
    go
    sp_configure 'max server memory', "4096" ( I confuse how much memory to set..pls advice....)
    go
    so_configure 'min memory', ""(Please advice also....)
    reconfigure
    go
    run the script....
    Something wrong with my step?
    How can I check if AWE has already enabled in SQL? Please Advice....

  2. satya Moderator

    Have you restarted SQL Server services?
    As after the restart, check the SQL Log in Enterprise Manager right away. The most recent startup log should contain the words “Address Windowing Extensions enabled” early in the log. If you didn’t do it right, the log should say, “Cannot use Address Windowing Extensions because…”. The reasons for this message will be noted, such as not assigning “lock pages in memory”.
  3. angelo_theus New Member

    Ok, I will try to restart the services and see the LOG file in mssql folder.
    And how about set min server memory and max server memory? My server has 6GB and the SQL is uses as database for ERP system who has 80 sessions(users) connect to the server.

    Please advice....
    rgds,
    Angelo

Share This Page