SQL Server Performance

error con TEXTIMAGE_ON

Discussion in 'Preguntas sobre SQL Server en Español.' started by Jako, Jun 23, 2004.

  1. Jako New Member

    Ante todos buenas tardes...
    Estoy tratando de crear un script de una tabla ya hecha y el script que me aparece me dice que tiene TEXTIMAGE_ON [PRIMARY] porque deberia tener campos text o ntext.
    Ahora el problema es que los campos que ya estan en la base de datos no tienen ningun tipo ni text ni ntext pero lo mismo me pone al final del script al crear la tabla la leyenda TEXTIMAGE_ON [PRIMARY]y al querer correr el script me da error.
    Bueno muchas gracias ante todo y espero que me puedan ayudar
    Gracias
  2. Luis Martin Moderator

    El problema puedes estar en que los campos text, ntext o image, esten en otro filegroup.
    Si en el momento de crear la tabla se definión TEXTIMAGE_ON, entonces es posible que estos campos se encuentren en otro filegroup.

    Si no se hubiera definido TEXIMAGE_ON, entonces los campos text, ntext o image se almacena en el mismo filegroup que la tabla.






    Luis Martin
    Moderator
    SQL-Server-Performance.com

    All postings are provided “AS IS” with no warranties for accuracy.

  3. Jako New Member

    Muchas gracias Luis!!!
    ahora te voy a seguir "molestando" con mis preguntas...
    puede ser que se hayan declarado campos del tipo text y luego se borraron pero quedo la referencia en esa tabla?
    bueno muchas gracias Luis
  4. Luis Martin Moderator

    Si, es totalmente posible.

    Nunca las preguntas son molestas, solo tienes que tener un poco de paciencia, ya que soy el único moderador de este Forum y cuando algo no lo se, cosa que es frecuente, lo consulto con los otros integrantes y tarda un poco.

    Saludos y bienvenido.



    Luis Martin
    Moderator
    SQL-Server-Performance.com

    All postings are provided “AS IS” with no warranties for accuracy.

Share This Page