SQL Server Performance

Error initializing RS and running rsactivate

Discussion in 'SQL Server Reporting Services' started by lidsurfer, Nov 4, 2004.

  1. lidsurfer New Member

    Hi there...

    I have an urgent problem I hope someone can help me with.

    I have recently attempted to install Reporting Services on a clients Win2K server (SP4) which is not a domain controller. At the end of the installation it said it could not initialize the report server and that I needed to do it manually...I attempted to do this by:

    So I went to:

    http://uacl-sql2/reports

    It redirects to:
    http://uacl-sql2/reports/Pages/Folder.aspx

    And I get the following error:

    An internal error occurred on the report server. See the error log for more details. (rsInternalError) Get Online Help The system cannot find the file specified.

    Does anyone know how to fix this....I have ensured that my Reports folder allows everyone to have full access....so I do not believe it is a security issue?

    I tried to run the rsactivate utility to manually initialize the report server and got this error...not sure if they are one and the same problem or not, but i am guessing they are...

    Here is the error when running rsactivate:

    "Unable to find Reporting Services WMI namespace =
    on Ullaksql1. Reporting Services may not be installed"

    As I mentioned, I need help urgently, so any suggestions would be welcomed.

    Thank you

    Jared.
  2. lidsurfer New Member

    Furthermore:<br /><br />I get an error when manually trying to initialize my report server. It says "The system cannot find the file specified." The service appears to be running fine, however, in the log (pasted below), it has the same error after restarting, as above....<br /><br /><br /><br />&lt;Header&gt;<br /> &lt<img src='/community/emoticons/emotion-4.gif' alt=';P' />roduct&gt;Microsoft SQL Server Reporting Services Version 8.00.743.00&lt;/Product&gt;<br /> &lt;Locale&gt;en-US&lt;/Locale&gt;<br /> &lt;TimeZone&gt;New Zealand Daylight Time&lt;/TimeZone&gt;<br /> &lt<img src='/community/emoticons/emotion-4.gif' alt=';P' />ath&gt;C:program FilesMicrosoft SQL ServerMSSQLReporting ServicesLogFilesReportServerService__11_08_2004_13_41_25.log&lt;/Path&gt;<br /> &lt;SystemName&gt;UACL-SQL2&lt;/SystemName&gt;<br /> &lt;OSName&gt;Microsoft Windows NT 5.0.2195.0&lt;/OSName&gt;<br /> &lt;OSVersion&gt;5.0.2195.0&lt;/OSVersion&gt;<br />&lt;/Header&gt;<br />ReportingServicesService!library!c38!11/8/2004-13:41:25:: i INFO: Initializing ConnectionType to '0' as specified in Configuration file.<br />ReportingServicesService!library!c38!11/8/2004-13:41:25:: i INFO: Initializing IsSchedulingService to 'True' as specified in Configuration file.<br />ReportingServicesService!library!c38!11/8/2004-13:41:25:: i INFO: Initializing IsNotificationService to 'True' as specified in Configuration file.<br />ReportingServicesService!library!c38!11/8/2004-13:41:25:: i INFO: Initializing IsEventService to 'True' as specified in Configuration file.<br />ReportingServicesService!library!c38!11/8/2004-13:41:25:: i INFO: Initializing PollingInterval to '10' second(s) as specified in Configuration file.<br />ReportingServicesService!library!c38!11/8/2004-13:41:25:: i INFO: Initializing MemoryLimit to '60' percent as specified in Configuration file.<br />ReportingServicesService!library!c38!11/8/2004-13:41:25:: i INFO: Initializing RecycleTime to '720' minute(s) as specified in Configuration file.<br />ReportingServicesService!library!c38!11/8/2004-13:41:25:: i INFO: Initializing MaximumMemoryLimit to '80' percent as specified in Configuration file.<br />ReportingServicesService!library!c38!11/8/2004-13:41:25:: i INFO: Initializing MaxAppDomainUnloadTime to '30' minute(s) as specified in Configuration file.<br />ReportingServicesService!library!c38!11/8/2004-13:41:25:: i INFO: Initializing MaxQueueThreads to '0' thread(s) as specified in Configuration file.<br />ReportingServicesService!library!c38!11/8/2004-13:41:25:: i INFO: Initializing MaxActiveReqForOneUser to '20' requests(s) as specified in Configuration file.<br />ReportingServicesService!library!c38!11/8/2004-13:41:25:: i INFO: Initializing MaxScheduleWait to '5' second(s) as specified in Configuration file.<br />ReportingServicesService!library!c38!11/8/2004-13:41:25:: i INFO: Initializing DatabaseQueryTimeout to '120' second(s) as specified in Configuration file.<br />ReportingServicesService!library!c38!11/8/2004-13:41:25:: i INFO: Initializing InstanceName to 'MSSQLSERVER' as specified in Configuration file.<br />ReportingServicesService!library!c38!11/8/2004-13:41:25:: i INFO: Initializing ProcessRecycleOptions to '0' as specified in Configuration file.<br />ReportingServicesService!library!c38!11/8/2004-13:41:25:: i INFO: Initializing RunningRequestsScavengerCycle to '60' second(s) as specified in Configuration file.<br />ReportingServicesService!library!c38!11/8/2004-13:41:25:: i INFO: Initializing RunningRequestsDbCycle to '60' second(s) as specified in Configuration file.<br />ReportingServicesService!library!c38!11/8/2004-13:41:25:: i INFO: Initializing RunningRequestsAge to '30' second(s) as specified in Configuration file.<br />ReportingServicesService!library!c38!11/8/2004-13:41:25:: i INFO: Initializing CleanupCycleMinutes to '10' minute(s) as specified in Configuration file.<br />ReportingServicesService!library!c38!11/8/2004-13:41:25:: i INFO: Initializing SecureConnectionLevel to '0' as specified in Configuration file.<br />ReportingServicesService!library!c38!11/8/2004-13:41:25:: i INFO: Initializing DisplayErrorLink to 'True' as specified in Configuration file.<br />ReportingServicesService!resourceutilities!c38!11/8/2004-13:41:25:: i<br />INFO: Running on 2 physical processors, 4 logical processors<br />ReportingServicesService!resourceutilities!c38!11/8/2004-13:41:25:: i<br />INFO: Reporting Services starting SKU: Standard<br />ReportingServicesService!runningjobs!c38!11/8/2004-13:41:25:: i INFO: Database Cleanup (NT Service) timer enabled: Cycle: 600 seconds<br />ReportingServicesService!runningjobs!c38!11/8/2004-13:41:25:: i INFO: Running Requests Scavenger timer enabled: Cycle: 60 seconds<br />ReportingServicesService!runningjobs!c38!11/8/2004-13:41:25:: i INFO: Running Requests DB timer enabled: Cycle: 60 seconds<br />ReportingServicesService!runningjobs!c38!11/8/2004-13:41:25:: i INFO: Execution Log Entry Expiration timer enabled: Cycle: 44314 seconds<br />ReportingServicesService!runningjobs!c38!11/8/2004-13:41:25:: i INFO: Memory stats update timer enabled: Cycle: 60 seconds<br />ReportingServicesService!crypto!1140!11/8/2004-13:41:25:: i INFO: Initializing crypto as user: UACL-SQL2Administrator<br />ReportingServicesService!crypto!1140!11/8/2004-13:41:25:: i INFO: Exporting public key<br />ReportingServicesService!library!1140!11/8/2004-13:41:25:: Exception caught while starting service. Error: System.IO.FileNotFoundException: The system cannot find the file specified.<br /> at System.Runtime.InteropServices.Marshal.ThrowExceptionForHR(Int32<br />errorCode, IntPtr errorInfo)<br /> at RSManagedCrypto.RSCrypto.ExportPublicKey()<br /> at<br />Microsoft.ReportingServices.Library.ConnectionManager.GetEncryptionKey()<br /> at Microsoft.ReportingServices.Library.ConnectionManager.ConnectStorage()<br /> at<br />Microsoft.ReportingServices.Library.ConnectionManager.VerifyConnection()<br /> at<br />Microsoft.ReportingServices.Library.ServiceController.ServiceStartThread()<br />ReportingServicesService!library!1140!11/8/2004-13:41:25:: Attempting to start service again...<br />
  3. sid New Member

    Hi lidsurfer,

    I am getting the same message... Were you able to resolve this ??
    Unable to find Reporting Services WMI namespace

    Thanks,
  4. lidsurfer New Member

    Nope. Ended up re-installing on a competely different server and it worked fine. Very frustrating as we never resolved it.

Share This Page