SQL Server Performance

FYI: MSDTC and SQL on Windows 2003

Discussion in 'Contribute Your Performance and Clustering Tips' started by Argyle, Mar 11, 2004.

  1. Argyle New Member

    Just thought I should post the following article:

    HOWTO: Enable DTC Between Web Servers and SQL Servers Running Windows Server 2003
    http://support.microsoft.com/?kbid=555017

    I had some issues getting distributed transactions to work between a SQL 2000 on a Windows 2003 machine and a SQL 2000 on a Windows 2000 machine. The above article supplied the solution. MSDTC is locked down harder in Windows 2003 and SQL 2000 will not be able to utilize it by default for external communication.

    Note that you can skip the part about VPN configuration in Windows if you have a hardware configured VPN. This is what I had to do to get it to work:

    -------------
    Step One: Steps to Enable Network DTC Access (Run on all machines requiring DTC access)
    1. Click Start, point to Control Panel, and then click Add or Remove Programs.
    2. Click Add/Remove Windows Components.
    3. Select Application Server, and then click Details.
    4. Select Enable network DTC access, and then click OK.
    5. Click Next.
    6. Click Finish.
    7. Stop and then restart the Distributed Transaction Coordinator service.
    8. Stop and then restart any resource manager services that participates in the distributed transaction (such as Microsoft SQL Server or Microsoft Message Queue Server).

    Step Four: Enable NETBIOS Across All MachinesAlternatively, you can add entries in the HOSTS file (c:windowssystem32driversetc) so that the machines can be pinged by server name. See the comments in the HOSTS file for more information on how to accomplish this.

    Step Five: Disable RPC Security for MSDTC Service on SQL Server
    This step requires accessing and modifying the registry. If you have not already done so, it is highly recommended that you back up the registry at this time.
    1. Click Start, click Run, type in "Regedt32", and click OK.
    2. Select HKEY_LOCAL_MACHINE, then SOFTWARE, then Microsoft.
    3. Right-click on MSDTC, point to Add, then select DWORD Value.
    4. Rename the key from the default New Value #1 to TurnOffRpcSecurity.
    5. Double-click the new key and change the value to 1.
    6. Close the Registry Editor and restart the SQL Server
    -------------
  2. kernelcache New Member

    This helped a ton!!!!

    I have looked at over 100 responses to this particular problem and this is the first one that actually had something that worked.

    Thanks much.

    Dan
  3. satya Moderator

    http://support.microsoft.com/?kbid=834849 latest fix to the problem on non Win2K3.

    Satya SKJ
    Moderator
    http://www.SQL-Server-Performance.Com/forum
    This posting is provided “AS IS” with no rights for the sake of knowledge sharing.

Share This Page