SQL Server Performance

HELP Replication Error The device is not ready.

Discussion in 'SQL Server 2005 Replication' started by m1k, Jun 13, 2008.

  1. m1k New Member

    Hello together,
    I am new on SQL Server Replication handling. Actually I try to test the replication and I stock always with the same error , it doesn´t matter
    what permissions I am using , I´ve tried with domain admins, sa , EVERTHING but I receive always this message when I watch into the Rplication Monitor:
    I hope you can help me, it´s pretty urgent :-/Command attempted:E:MSSQL.1MSSQLReplDatauncNVDERAU01_BELGIUM_BELGIUM_REPL20080611160397Windows Login_2054.pre
    (Transaction sequence number: 0x00000B6800005D1600D500000000, Command ID: 2057)Error messages:The process could not read file 'E:MSSQL.1MSSQLReplDatauncNVDERAU01_BELGIUM_BELGIUM_REPL20080611160397Windows Login_2054.pre' due to OS error 21. (Source: MSSQL_REPL, Error number: MSSQL_REPL20024)
    Get help: http://help/MSSQL_REPL20024
    The device is not ready.
    (Source: MSSQL_REPL, Error number: MSSQL_REPL21)
    Get help: http://help/MSSQL_REPL21
  2. techbabu303 New Member

    Are doing Transaction replication and How many table's ?
    have you set up subscriber and publisherdistributor in same machine or different machine ? If yes check if you network connectivity in both and also if they are in same domains.
    I did find similar error messages but with OS error 5.
    Sat

Share This Page