SQL Server Performance

How to stop log recovery on SQL server startup?

Discussion in 'General DBA Questions' started by amu_27, Oct 4, 2007.

  1. amu_27 New Member

    How can I stop log recovery on startup as database is not able to recover due to out of space on log drive? Database is recovering up to 100% and start the recovery again as there is no space on log drive. How can I stop? should simple kill, sp_detachdb, etc works or help? Thanks for your help in advance.
  2. bradmcgehee New Member

    I am not familiar with any way to prevent SQL Server from recovering. This is a built-in process. Based on what you said, it sounds like your disk space if full. Is this correct? If so, haven't you tried to delete any unnecessary files in order to make more room available.
  3. ghemant Moderator

    If I understand properly you are talking about the message recovering database 'dbname' everytime server restarts! This message appears if you have uncommited transaction in your db while your server shutdown and after server restarts it will start working on this uncommited transactions, refer http://www.microsoft.com/technet/prodtechnol/sql/2000/maintain/sqlbackuprest.mspx
    Are you facing space crunch? What is your recover model? Have you schedule T-Log backup for your db to keep your T-Log in shape?
  4. satya Moderator

    I believe the problem is with low disk space where these data &* log files are located, it is not possible to stop recovery when the SQL services are started. Rather you could try adding more sapce to the database before starting it up again.
  5. thomas New Member

    You can bypass recovery of user databases in SQL Server by starting sql server with trace flag 3607.
    http://www.windowsitlibrary.com/Content/77/19/2.html
    You won't be able to access the database if it hasn't recovered though, so I don't know how much help this will be to you.

Share This Page