SQL Server Performance

Large files copies error out

Discussion in 'SQL Server DTS-Related Questions' started by dilan, Aug 22, 2007.

  1. dilan New Member

    Hi -
    I am trying to copy a database backup from one machine to another. Currently I am doing this in DTS using VBScript code using FSO. The file being copied is about 80gigs. I have tried this a few times now and I can't seem to successfully copy the file. Anywhere from 10 to 50 minutes the copy process seems to die. The error message is shown below. Any ideas? Is FSO the right tool to copy this large a file?
    Step Error Source: Microsoft Data Transformation Services (DTS) Package
    Step Error Description:ActiveX Scripting encountered a Run Time Error during the execution of the script.
    Step Error code: 800403FE
    Step Error Help File:sqldts80.hlp
    Step Error Help Context ID:4500
  2. ghemant Moderator

    It should copy the files with this too, but why you don't use copy/xcopy/robocopy! Ensure their is not network congessions
  3. satya Moderator

    Yes FSO is better to deal with such tasks.
    Try to execute step by step on DTS designer to see where the timeout problem, if you are executing this within a SQL agent job then ensure the SQLAgent service account has relevant privileges on the specified file path &Share.
  4. martins New Member

    And also don't forget to check whether it isn't maybe your antivirus scan that is interfering with the file copy.
  5. dilan New Member

    Thanks guys.
    The script ran fine last night. Network congestion could have been an issue as I was testing during the day time. However the servers are on a switched gig network. Virus scanning is a possibility. I will try to add the relevant folders to the exclusion list. Not sure how I can get detailed failure info from FSO when something like this happens. I will try and figure that out.
  6. satya Moderator

    May be you could enable LOGGING on that DTS package to get more information when it fails, better to exclude the AV scanning in this regard and also avoid running during thsi operation due to the sheer size of data.
  7. dilan New Member

    This issue is back to haunt me :(
    I did have logging turned on in DTS and the message I posted was from the log.
    I tried using Robocopy to see if it can help and saw the following message:
    Insufficient system resources exist to complete the requested service.
    Waiting 30 seconds... Retrying...
    While looking into this I ran into this post:
    http://blogs.technet.com/askperf/archive/2007/05/08/slow-large-file-copy-issues.aspx
    Could this be the problem with FSO as well? Any thoughts on if FSO might be suffering from the same issue?
  8. satya Moderator

    Do you have any antivirus or firewall associated on the network?
    The error sounds like the system is struggling for resource to copy thsi file, in general FSO depends upon the available memory.
  9. dilan New Member

    This server has 8gigs of memory, is a dual xeon dual proc machine. Lots of places mention about running out of paged pool etc with large file copies due to buffering. Since this is a production machine I am a bit reluctant to jump and make changes. I guess I will have to look at some other method like FTP. Thanks.
  10. satya Moderator

    You haven't cleared the question about running other applications on this server?
    Also check the network contention as using such a big file copy operations, if any issues on a hub or switch might give such problems.

Share This Page