SQL Server Performance

log shipping errors

Discussion in 'SQL Server Log Shipping' started by mgole, Mar 10, 2005.

  1. mgole New Member

    Hi<br /><br />I have set up log shipping.The backup and restore jobs are working fine.<br />But there are a few errors like 3101 and 3201 in the log_shipping_plan_history table.<br /><br />Also there are some entries in the sql server logs such as<br /><br />"bypassing recovery for database 'xxxxx' because it is marked IN LOAD<br /><br />and<br /><br />"BackupDiskFile<img src='/community/emoticons/emotion-3.gif' alt=':O' />penMedia:Backup Device 'e:mssqlhotstandby_log_backup_device'<br /><br />I have set up copy/restore time to 5 min and backup time is also 5 min.I am sending large burst of transactions say 15 transactions/sec (total abt 4000 transactions in one burst)..<br /><br />Are these errors due to low copy/restore time.Should i increase it?<br /><br />Thanks<br /><br />Madhukar
  2. satya Moderator

    The error 'bypassing recovery...' is an informational message when the SQL is trying to check th database status, and it will bypass because the secondary server's database is on LOADING state.

    For the second error try to specify the fully qualified name as \servernamepathackupdiskname... not the drive name and ensure the SQLAgent has required privileges to manage the files.

    Satya SKJ
    Moderator
    http://www.SQL-Server-Performance.Com/forum
    This posting is provided “AS IS” with no rights for the sake of knowledge sharing.
  3. bsat New Member

    We are getting the same error like:

    2005-05-03 16:00:01.59 spid56 Bypassing recovery for database 'unac_db' because it is marked IN LOAD.
    2005-05-03 16:00:01.75 spid56 Starting up database 'unac_db'.
    2005-05-03 16:00:01.78 spid56 Bypassing recovery for database 'unac_db' because it is marked IN LOAD.
    2005-05-03 16:00:02.17 spid56 Recovery is checkpointing database 'unac_db' (7)
    2005-05-03 16:00:02.34 backup Log restored: Database: unac_db, creation date(time): 2004/06/19(08:17:33), first LSN: 235:1331:1, last LSN: 235:1331:1, number of dump devices: 1, device information: (FILE=1, TYPE=DISK: {'d:MSSQL$MQCS_PRODBACKUPunac_db_tlog_200505031500.TRN'}).

    BUT this has been going on since the last time the secondary/standby server was recycled. Could it be that its not able to catch up with the logs being loaded? Our transaction log dumps are happeneing every 30 minutes on primary server and copy/backup parameters are set to 45 minutes.

    Appreciate any help to resolve the issue.
  4. satya Moderator

    The Bypassing message is by default because the database is in loading state and you shouldn't worry much about it, as it is on the secondary server. Ensure the Tlogs are restored properly and as you can see the corresponding entries.

    All the messages pertaining to BACKUP/RESTORE will be logged to the SQL Server error log.

    Satya SKJ
    Moderator
    http://www.SQL-Server-Performance.Com/forum
    This posting is provided “AS IS” with no rights for the sake of knowledge sharing.

Share This Page