SQL Server Performance

log shipping_primaries not updated due to the value in the primary_server_name not match the @@servername

Discussion in 'SQL Server Log Shipping' started by jessie, Aug 22, 2007.

  1. jessie New Member

    The log_shipping_primaries and the log_shipping_secondaries tables are updated based on the SQL Server server names. You must runSelect @@servername
    on both primary and secondary servers. Then, verify that the values in the primary_server_name and the secondary_server_name columns of the tables in the Monitor server match the @@servername values respectively.
    My current situation is the values in the primary_server_name is '(local)' and @@servername is 'QNXT1' IS any body know how I can fix it?
    Can I update table on msdb set 'QNXT1' instead of '(local)'?
    Many thanks!
    Jessie
  2. jessie New Member

    After doing some research, I found some one solved this issue, now I re-resistered all 3 servers that were involved in the log shipping and remove the (local), but I am not clear about perform the wizard from scratch. What does this mean? perform which wizard? Is any one have idea after looking at the following message?
    Thanks!
    Jessie
    "When the Log Shipping wizard was run, it was started from a sql server
    registered as (Local). What this resulted in was entries in the
    Log_Shipping_Primaries table with a server name of (Local). When the stored
    procedure to update the Primaries table was executed the Where clause used
    the actual Server name instead of (Local). Which did not find a row to
    update.

    I re-registered all 3 servers that were involved in the log shipping and
    remove the (local) and perform the wizard from scratch. The server name in
    the Primaries table is now the actual server name instead of (local)."


  3. jessie New Member

    Now I re-resistered all 3 servers that were involved in the log shipping and remove the (local), but I am not clear about perform the wizard from scratch. Is any one have idea?
    Thanks!
    Jessie
  4. satya Moderator

  5. jessie New Member

    Thanks Satya, Do I need to remove the current log shipping first, then use wizard to re-set up log shipping? It seemed that I can't modify log shipping when I select the db which on log shipping, the log shipping check mark was disabled.
    Jessie
  6. satya Moderator

    Better to remove current LS in this case and start afresh.
  7. jessie New Member

    I am so appreciated your help!
    Thanks!
    Jessie

Share This Page