SQL Server Performance

Log Shopping Restore Job Failing

Discussion in 'SQL Server Log Shipping' started by photura, Jun 8, 2006.

  1. photura New Member

    Hello.

    I setup log shipping to a remote server. The inital transfer and restore works but restore fails each time after that and does not give any error info other than 'failed.'

    Any thoughts what could be causing this?
  2. nigelrivett New Member

    Did you leave the resored database in a condition to receive furtherlog restores? i.e. didn't recover it.

    Are you missing some logs?

    Think they would botyh give a message though.

    Any non-logged ops on the source.

    This happened to me when the database was on dodgy disks. Every time there was a write error (not enough to cause apparent problems on the source) the log restore would fail. That was every couple of days.
  3. smy New Member

  4. satya Moderator

    Also chekc MDAC tools and similar levels of SP/Hotfixes in this case.

    Satya SKJ
    Microsoft SQL Server MVP
    Contributing Editor & Forums Moderator
    http://www.SQL-Server-Performance.Com
    This posting is provided �AS IS� with no rights for the sake of knowledge sharing.
  5. photura New Member

    I checked all of that.

    The next thing I'm going to try is to completely delete the copy of the database from the standby server and let Log Shipping create, backup and restore and see if that works.


    quote:Originally posted by nigelrivett

    Did you leave the resored database in a condition to receive furtherlog restores? i.e. didn't recover it.

    Are you missing some logs?

    Think they would botyh give a message though.

    Any non-logged ops on the source.

    This happened to me when the database was on dodgy disks. Every time there was a write error (not enough to cause apparent problems on the source) the log restore would fail. That was every couple of days.
  6. nigelrivett New Member

Share This Page