SQL Server Performance

log_shipping_secondaries out of sync!

Discussion in 'SQL Server Log Shipping' started by jonathan_hwang, Mar 16, 2006.

  1. jonathan_hwang New Member

    I got a very strange issue. My log shipping monitoring had been working for a long time. However, it broke this morning.

    Table on my primary server dbo.log_shipping_secondaries kept saying the last update was a while back. However my secondary server is not out of date! It has been restoring and copying correctly as a standby!

    And the odd thing is when I go to my primary server (where my log monitoring is at) and I right click to view the backup and restore history. Everything seems to be successful...all my files are copied and loaded correctly!

    So why isn't this log shipping secondaries table get updated correctly?

    I went through this artical and non of the those are causes of that...
    http://support.microsoft.com/default.aspx?scid=kb;en-us;329133

    Anyone know what might had caused this? Also how can I re-setup this borken log monitoring?
  2. satya Moderator

    Right check if there are any network issues between primary and secondary servers.

    To enable the log shipping cycle, you need to restore latest backup from primary to secondary. If not see last restored log on secondary and continue the next cycle by taking informaton from primary.

    If you have restored the latest database from P to S then you can re-enabled the lgoshipping schedule to continue. Also ensure both the servers are in similar levels of service pack & hotfixes including SQL and operating system.

    Satya SKJ
    Contributing Editor & Forums Moderator
    http://www.SQL-Server-Performance.Com
    This posting is provided “AS IS” with no rights for the sake of knowledge sharing.

Share This Page