SQL Server Performance

Nightmare scenario - can't start sql server after running sqlservr.exe -c -m -T3608

Discussion in 'General DBA Questions' started by Trev256, Sep 24, 2007.

  1. Trev256 New Member

    Iv'e run the above because setting the startup parameters in enterprise manager didn't work.
    The sql server2000 won't start now!!!
    I've tried to remove the startup parameters but this hasn't worked.
    Someone has setup a clustered sql server on a single node (physical machine) - is this usual practice and are there severe problems with this configuration I should be aware of???
    Thanks and help!!![:'(]
  2. bradmcgehee New Member

    I am not entirely clear on what you are doing.
    Did you run the first command, sqlservr.exe -c -m -T3608, from the command line, or did you try to run it from Enterprise Manager? I am assuming you have done this from the command line.
    When you say SQL Server won't start, are you starting it from the command line, or are you starting it as a service?
    Have you checked the Windows Event and SQL Server logs to see if they provide any useful information?
    Have you tried to start SQL Server from the command line using default settings to see if it starts?
    What is the purpose of running this command in the first place?
  3. Trev256 New Member

    Hi - I've got the service started but still can't move the system databases.
    I am trying to move the system databases on SQL Server 2000. However, I have discovered this is on a SQL Server Cluster on a single node (physical machine) - Someone has configured it to not use another node. Is there a special method for moving system databases on a SQL Server 2000 cluster?
    Thanks
    Matt
  4. satya Moderator

  5. Trev256 New Member

    Hi
    I need to move the system databases not restore master. I'm wondering do I need to take SQL Server offline in cluster administrator then stop SQL Server, then stop sql server servoce in service manager (SQL2000), then restart SQL Server with parameters -c -m -T3608. Then move databases????
  6. satya Moderator

  7. Trev256 New Member

    I have followed this document to move all system databses (model, msdb, master and tempdb).
    I can't move the first one (model) - I've tried to restart sql server in enterprise manager and via cmd prompt. Via cmd prompt it starts but then pauses at 'SQL Server is ready for client connections'.....?
  8. Trev256 New Member

    This is the latest I've got from the command prompt - when ensureing correct disk drives are online and registry is amedning to point to these disk drives.
    Command Prompt: SQL Server could not spawn FRunCM thread
    Any ideas??????????[:^)]
  9. satya Moderator

    Is this a SQL 2005 setup?
    What are the enabled protocols on this SQL instance?
  10. Trev256 New Member

    This is a SQL Server 2000 cluster.
    I'm nowing having problems starting the sql service again.
    In the client network utility (if this is the right place to check) TCP/IP and named pipes are enabled.
    Thanks....
  11. satya Moderator

    Explain the steps you have followed in moving the system databases.
  12. Trev256 New Member

    OK steps followed:
    1) Backed up databases.
    2) Followed instruction in 'how to move...' doc you sent link for - such as:
    3) Moved User databases - this was successful - user databases now in read only mode.#
    4) Tried to move model database - stopped sqlserver agent service.
    5) Remember this is on a strnage configuration - it is a sql server cluster on a single nod or physical machien - without any other no or physical machone ever existing!! There is no documentation for this so I can't tell what was done in the past.
    6) then I changed the start up parameters - I added this parameter in the server properties | Startup parameters: '-c -m -T3608' (without inverted commas)
    7) I then tried to stop and start sql server in enterprise manager (not cluster administrator or service manager) - this did not start sql server in single user mode etc.
    8) I then typed 'sqlservr.exe -c -m -T3608' in the cmd prompt (correct directory) - I got this to work eventually and the SQL Server enterprise manager started in single user mode although I was getting the 'not spawn FRunCM thread' error.
    9) I could not access sql server enterprise manager because it is in single user mode. The 'sa' password was documented incorrectly so I had to restart sqlserver.
    Question 1: How do I detach the model database if I can't access enterprise manager??
    10) I tried to stop sqlserver and start it by running 'sqlserver.exe' only without the startup parameters (so I could create a 'sa' password) - now I can't start sqlserver via enterprise manager, service manager, cluster administrator or the command prompt.
    Question 2: How can I get SQL server started again? What is the correct method or order to use?
    Question 3: Why does the service manager (bottom right of screen) list the physical server name (eg. 02) and enterprise manager list the instance name (e.g. 04) ? NB. These are also differently named.
    Thanks!
  13. satya Moderator

    If another connection is using the SQL Server then you may not be able to use in single-user mode by default. If you are unable to use via EM then you can take help of query analyzer. As referred on that KBA you should use SP_DETACH_DB and move the fles then SP_ATTACH_DB.
  14. Trev256 New Member

    See previous reply - Also: SQL Server has 'failed' in cluster administrator - I can't bring this online.
  15. satya Moderator

    You should check event viewer and cluster log in thsi case why the SQL resources are not getting online,
  16. Trev256 New Member

    Where is the cluster log?
  17. Trev256 New Member

    I can't find cluster log - where is it?
    Other behaviour of the system includes:
    1) I managed to start SQL Server in single user mode etc (-c -m -T3608) - but when I tried to restart the SQL Server service it wouldn't let me - I tried to restart the sql service via the command propmt but it would not start.
    2) After deleting the startup parameters and even editing the errolog parameter drive in the registry - these setting 're-appear' after a reboot of the server.
    3) I can open SQL Server enterprise manager and see all the databases etc but it is showing with a red square - suggesting the service is not running! Also under 'services' the sql server service is not running! How can I open enterprise manager whilst the service is not running? How can I determine what is going on???
    4) Event Viewer error is: [sqsrvres] OnlineThread:Error435 bringing resource online
    Any ideas??
  18. Trev256 New Member

    I've fixed error 2 - with the 'clusterrecovery' tool.
    I still can't start sql server or bring online sqlserver in clusteradministrator.... help!![*-)]
  19. satya Moderator

    Strange no one picked up in my absence!
    Cluster log file is located under C:WindowsCluster direcory.
    It seems the dependant resources are not valid to bring the SQL group online, first you have to fix the databases move and then come to cluster.

Share This Page