SQL Server Performance

Performance Concern with Lock Pages in Memory Option

Discussion in 'Performance Tuning for DBAs' started by DBADave, Aug 29, 2007.

  1. DBADave New Member

    I ran across the following link regarding Lock Pages in Memory. The link is in the 2005 BOL, but my question is does it apply also to SQL 2000. The following statement has me concerned.
    "On 32-bit operating systems, setting this privilege when not using AWE can significantly impair system performance."
    http://msdn2.microsoft.com/en-US/library/ms190730.aspx
    I believe with SQL 2000 Lock Pages in Memory is automatically set for the service account used to install SQL Server. If you change service accounts after the installation the option must be manually set. My question is does the above warning only apply to SQL 2005 or also to SQL 2000?
    Thanks, Dave
  2. satya Moderator

  3. DBADave New Member

    Hi Satya,
    The KB you reference refers to the use of Lock Pages in Memory in conjunction with AWE. The link I found talks about the impact of Lock Pages in Memory when not using AWE. Do you still believe the warning offered in the BOL link pertains only to SQL 2005?
    Thanks, Dave
  4. satya Moderator

    I haven't had such problem within my environment for 2000 version, but I think I have seen article states you may need this in SQL 2000 too, let me find it out.
  5. DBADave New Member

    Thanks. The only SQL 2000 articles I have found regarding this option pertain to using AWE. They don't say anything about what the impact is if you are not using AWE. That being said, I believe this option is turned on by default in SQL 2000, which would make me believe it should not be a performance problem. In other words, I have no idea.
    Dave
  6. jl999 New Member

    Confirmed. I just installed a SQL 2000 ent on Win 2003 ent (32-bit) with 8GB physical memory. Much to my surprises the account that runs SQL engine was automatically added to the Lock Pages in Memory list.
    I wonder why SQL 2005 doesn't do that. For 64-bit version (both Win 2003 and SQL 2005), I had to manually add the account to that policy.
    Jason

Share This Page