SQL Server Performance

Problem Connnecting to SQL Server 2008 over LAN

Discussion in 'SQL Server 2008 General DBA Questions' started by vexilar, Jun 29, 2009.

  1. vexilar New Member

    First off, I don't know much about networking which is probably why I am having problems. I do know that I have two computers that connect to the internet via a router. The IP of the computer running the SQL Server is 192.168.0.71 and the computer name is SEAN. The other computer is the one that is trying to connect to the SQL Server; it is named MATT and it's ip is 192.168.0.114. From MATT I can ping 192.168.0.71 and also I can ping this machine by typing 'ping sean'. When I do this it starts off by saying 'Pinging sean.gateway.2wire.net' etc. From SEAN I can ping 192.68.0.71 and also I can ping again using 'ping matt' but this time it says that I'm pinging a loopback 127.0.0.1 each time instead of matt's ip. Also here, matt is listed as 'matt.gateway.2wire.net'. I am hoping this background info is useful :-. So the problem is, from my .NET application running on SEAN I can connect to the SQL Server running on SEAN (SEANSQLEXPRESS), but when I run the same .NET application on MATT, I have been unable to do the same. These are the connection strings I have tried:
    I'm not sure if I'm doing something completely wrong with the connection string of if the network setup is getting in the way. With the last connection string I made sure to go into My Computer -> Manage -> Services and Applications -> SQL Server Configuration Manager -> SQL Server Network Configuration -> Protocols for SQLEXPRESS -> TCP/IP , and enable it with a port # 1433. Oh, and both computers are running Vista with no firewalls on (not even Windows Firewall). Any help on this issue will be GREATLY appreciated.

    Thanks,
    Sean
  2. moh_hassan20 New Member

    Welcome to the forum
    Be sure that TCP/IP is enabled for the server
    On the server SEAN , run configuration manager -> protocols for sqlexpress -> TCP enabled
    IP address tab , IPALL , TCP port 1433 , and dynamic port blank (not 0)
    connection string:
    DataSource=192.168.0.71,1433;Initial Catalog=SmartBidDatabase;UserID=sa;Password=SmartBid

Share This Page