SQL Server Performance

Problem in Deploying the Reports

Discussion in 'SQL Server 2005 Reporting Services' started by k_ashish2002, Dec 7, 2006.

  1. k_ashish2002 New Member

    Hi there,

    I am having the problem in deploying the report. While if I build or Run the report its working fine. Buti n deployment its giving me error. Will someone please give me some guidelines to deploy the reports.
    Thaks in advance.

    Regards
    Ashish Kuriyal
  2. simondm New Member

    Can you post the error message? If you are deploying the report and can see it from the report manager you have probably deployed correctly.

    It maybe a connection problem with the report datasource (or the datasource hasn't deployed).

    Simon
  3. smy New Member

    for deployment, you got to point to the reports server..on the properties where there's a targetserverurl, you need to indicatehttp://<servername>/ReportServer

    Also, are you using shared datasource? your datasource should be pointing to:
    data source=(the sql server name you are using);initial catalog=(your database name)

    try going tohttp://<servername>/reports and see if your report is already deployed there. Try to open the report and see if you got any error.
  4. k_ashish2002 New Member

    Thanks for the reply. I am trying to deploy the project using the same option from where I am running my reports. It gives me this error...


    TITLE: Microsoft Report Designer
    ------------------------------

    A connection could not be made to the report serverhttp://dbbomart103/reportserver.

    ------------------------------
    ADDITIONAL INFORMATION:

    The request failed with HTTP status 503: Service Unavailable. (Microsoft.ReportingServices.Designer)

    ------------------------------
    BUTTONS:

    OK

    -----------------------------

    Please guide me where am I doing the wrong?

    Ashish
  5. smy New Member

  6. k_ashish2002 New Member

    But I am not able to find the meaning of this error..

    The request failed with HTTP status 503: Service Unavailable. (Microsoft.ReportingServices.Designer)

    Will someone please clear the doubt?
  7. k_ashish2002 New Member


    As well this error...

    --------------------------------------------------------------------------------------------------
    The project cannot be deployed because no target server is specified. Provide a value for the TargetServerURL property in the property pages for this project.


  8. smy New Member

    u got to provide a server url in your project. open your project in visual studio and at the solution explorer, right click on the report project (above the shared data sources folder) and choose properties. There will be:

    - OverwriteDataSources -> change to true if you want to overwrite your datasource everytime you do a deployment

    - TargetFolder -> specified a name for the folder

    - TargetServerURL -> specified the server name where the report server is in. (for your case, itshttp://dbbomart103/reportserver)

    ----------------------------------------------------------------------------------------
    for HTTP status 503: Service Unavailable. (Microsoft.ReportingServices.Designer)
    - please check the server running this reporting server. check IIS manager to make sure its working fine.
    - try to ping the server using command prompt at your machine and check if you are able to obtain an IP address from the IP name of your server.
  9. k_ashish2002 New Member

    Great. Thanks a lot....

Share This Page