SQL Server Performance

Problem - SSRS 2005 and email subscriptions

Discussion in 'SQL Server 2005 Reporting Services' started by jimpromero, Apr 7, 2006.

  1. jimpromero New Member

    Hi -

    Having a problemm with email subscriptions on the following configuration:

    Win 2003 Enterprise
    SQL 2005 Enterprise
    Configured SSRS to use another server as the SMTP server

    Every time I schedule a subscription - it generates the following error:

    Failure sending mail: The report server has encountered a configuration error. See the report server log files for more information.

    I do find the following warnings in the ReportServerWebApp.log:

    The extension Report Server Email does not have a LocalizedNameAttribute
    The extension Report Server FileShare does not have a LocalizedNameAttribute.

    Do I need to add these attributes to the config file - if so is there an example of what is required?

    Any help appreciated - thanks.
  2. yulou New Member

    Hi,<br />I have email subscription problem too on the following configuration:<br /><br />Windows XP prof.<br />SQL Server 2005 Enterprise<br />Configured Database Mail with remote SMTP server to send email successfully<br />Configured SSRS to use remote SMTP server<br /><br />Edited the Rsreportserver.config file as following (by the instructions from MSDN)<br /><br />&lt;Configuration&gt;<br /> &lt;RSEmailDPConfiguration&gt;<br /> &lt;SMTPServer&gt;smtp.broadband.rogers.com&lt;/SMTPServer&gt;<br /> &lt;SMTPServerPort&gt;25&lt;/SMTPServerPort&gt;<br /> &lt;SMTPAccountName&gt;&lt;/SMTPAccountName&gt;<br /> &lt;SMTPConnectionTimeout&gt;&lt;/SMTPConnectionTimeout&gt;<br /> &lt;SMTPServerPickupDirectory&gt;&lt;/SMTPServerPickupDirectory&gt;<br /> &lt;SMTPUseSSL&gt;&lt;/SMTPUseSSL&gt;<br /> &lt;SendUsing&gt;2&lt;/SendUsing&gt;<br /> &lt;SMTPAuthenticate&gt;0&lt;/SMTPAuthenticate&gt;<br /> &lt;From&gt;My email Address&lt;/From&gt;<br /> &lt;EmbeddedRenderFormats&gt;<br /> &lt;RenderingExtension&gt;MHTML&lt;/RenderingExtension&gt;<br /> &lt;/EmbeddedRenderFormats&gt;<br /> &lt<img src='/community/emoticons/emotion-4.gif' alt=';P' />rivilegedUserRenderFormats&gt;&lt;/PrivilegedUserRenderFormats&gt;<br /> &lt;ExcludedRenderFormats&gt;<br /> &lt;RenderingExtension&gt;HTMLOWC&lt;/RenderingExtension&gt;<br /> &lt;RenderingExtension&gt;NULL&lt;/RenderingExtension&gt;<br /> &lt;RenderingExtension&gt;RGDI&lt;/RenderingExtension&gt;<br /> &lt;/ExcludedRenderFormats&gt;<br /> &lt;SendEmailToUserAlias&gt;True&lt;/SendEmailToUserAlias&gt;<br /> &lt;DefaultHostName&gt;&lt;/DefaultHostName&gt;<br /> &lt<img src='/community/emoticons/emotion-4.gif' alt=';P' />ermittedHosts&gt;&lt;/PermittedHosts&gt;<br /> &lt;/RSEmailDPConfiguration&gt;<br />&lt;/Configuration&gt;<br /><br />I scheduled my subscription and tested it. I didn't receive any mail from the setting email address, but got an error message in ReportServerService log file as following.<br /><br /> Error sending mail, CDO error -2147220978, will not resend<br /> Error sending email. System.Runtime.InteropServices.COMException (0x8004020E): The server rejected the sender address. The server response was: 530 authentication required - for help go to<a target="_blank" href=http://help.yahoo.com/help/us/mail/pop/pop-11.html>http://help.yahoo.com/help/us/mail/pop/pop-11.html</a><br /><br />I did a little search and do find the other people with the same issue, but couldn't find any solution for it. Is anybody successfully to get the Reporting Services subscription by email function working through MS SQL Server Management Studio or if you have a solution for this issue, would you mind to share the experience with me. I will be very appreciated. <br /><br />

Share This Page