SQL Server Performance

Query Analizer timeout

Discussion in 'General DBA Questions' started by justindk1, Nov 2, 2002.

  1. justindk1 New Member

    I was hoping on of you other forum members could give me a hand with this. I have just installed our new SQL server (MSSQL2000) and I am having a problem connecting to query analizer. I can connect just fine when I am in the server, but not as a user with the client adition. I keep on getting timeout expired. We have about 12 SQL servers set up, with 100 + databases on each instance and this is the only one I am having problems with. Can anyone help?
  2. bradmcgehee New Member

    The first thing I would check would be to see if you are using the same network library on the client and on the server. I suggest you use the TCP/IP network library for best overall performance.

    If that doesn't work, you can change the timeout period for Query Analyzer by going to it sessions properties, but this is not an ideal solution as it should't take very long to connect in the first place. If there is a long delay, the cause needs to be identified and corrected.


    ------------------
    Brad M. McGehee
    Webmaster
    SQL-Server-Performance.Com
  3. satya Moderator

    In addition to Brad's suggestion you have check thru the Server properties too.

    Make sure to have identical net library usage on server and client-side.

    Satya SKJ
  4. dataninja New Member

    You might also want to check your general connectivity from the client machine. I would try pinging the SQL server first, and then try to telnet to the server on the port that SQL is configured to listen on (1433 by default). If you can't telnet to the SQL server port, then I would look into your network configuration. Do you have a firewall set up? If so, make sure that TCP port 1433 is open and UDP port 1434 should be open as well if you have additional instances.

    MS has a nice article discussing the SQL server TCP configuration model:

    http://support.microsoft.com/default.aspx?scid=KB;EN-US;Q287932&

    One last thing you can try is setting up an alias in your client configuration utility which will allow you to specify an explicit port to connect on.

    -dataninja-

    "The normalcy of a database is inversely proportional to that of it's DBA."

Share This Page