SQL Server Performance

reinstall cluster node

Discussion in 'SQL Server 2005 Clustering' started by acki4711, Mar 12, 2007.

  1. acki4711 Member

    Hi all! It's me again <img src='/community/emoticons/emotion-1.gif' alt=':)' />)<br />Had a running a/p 2 node cluster with sql2005 SP2!!<br />One node died because of hardware failure.<br />Replaced hardware, reinstalled os, rejoined to the nt cluster.<br />(same hardware, same ip, same hostname)<br />try now reinstalling sql server on replaced node<br />running add remove programs / sql server 2005 / maintaining virtual cluster<br />checked that installation account is local admin on both nodes but still getting <br />error during installation:<br /><br />Summery log says:<br />-----------------<br />Error String : The source installation package for the product Microsoft SQL Server Setup Support Files (English) is out of sync with the client package. Try the installation again using a valid copy of the installation package 'SqlSupport.msi'. <br />Error Number : 1731 <br /><br />SQLSetup0001_&lt;replaced_node_name&gt;_Core.log:<br />-------------------------------------------<br />...<br />Installing from: \H033GUI$sql2005Ent_64Disk 1SetupSqlSupport.msi<br />Package: \H033GUI$sql2005Ent_64Disk 1SetupSqlSupport.msi Version installed: 9.00.3042.00<br />Package: \H033GUI$sql2005Ent_64Disk 1SetupSqlSupport.msi Version installing: 9.00.1399.06<br />Failed to install support files<br />Fatal error during installation.<br />Fatal error during installation.: (1603) {e:sql9_sp2_tsqlsetupsqlcudllcustomcomps.cpp:861}<br />SCU_SetupMgr:<img src='/community/emoticons/emotion-7.gif' alt=':s' />vc() caught exception: Fatal error during installation.: (1603) {e:sql9_sp2_tsqlsetupsqlcudllcustomcomps.cpp:861}. SetupMgr: state=ERROR, cancel_state=0, is_done=0, ActionRequired=1, NeedReboot=0, custom_props={AutoStart=true<br />...<br /><br />There seems to be a total messup with the installation files. Tried to install support files manualy on replaced node and restart virtual cluster maintenance again.<br />Installation advances a bit more but complains with other invalid .msi files.<br /><br />Any help is highly appreciated.<br />TIA<br />acki<br /><br />
  2. acki4711 Member

    OK,
    Installing support files and native client on the repaired node with applying sp2 made installation from primary node to run.

    HTH
    acki

Share This Page