SQL Server Performance

Remote Database connectivity problem

Discussion in 'SQL Server 2008 Questions [Archive Only - Closed]' started by btough, Jun 3, 2009.

  1. btough New Member

    I have to connect database remotely. For that I have done all the settings using SQL server configuration manager. I have set port number as 1433 the default one. Also added this port number into windows firewall exception list and turned it on. Now in my connection string, value of the "server" parameter is only "IPAddress". But while loading crystal report into CrystalReportViewer control it ask me for the Password to enter. I have set all Connectioninfo to the CtrystalReport at runtime, but till it ask for password . How can I solve this problem? If I use "IPAddress,1433" as the value of server parameter, it works fine. But as per my knowledge, 1433 is default port and need not to be include in the connection string. please help if anybody knows the solution. Thanks.
  2. moh_hassan20 New Member

    Is that server a named instance , or sql express ?
  3. btough New Member

    It is SQL Express. While installing SQL Server I selected "Default Instance" option.
    Thanks in advance.
  4. moh_hassan20 New Member

    For named instance, the connection string is:
    servernameinstancename
    or
    servername, port# , even the port# is 1433
    If SQL browser is running , you can pass server name only, and browser direct the client to the dedicated port

Share This Page