SQL Server Performance

Replication error - '-XParentProcessHandle' is not a valid parameter.'

Discussion in 'SQL Server 2005 Replication' started by WingSzeto, Aug 27, 2007.

  1. WingSzeto Member

    I am setting up a transactional replication between 2 SQL server 2k5 using push method. The distribution db is in the publisher server. It is a very simple setup and has been working for me before. But this time, when I start the snapshot agen after I create a new publication and a new subscription, I encounter an error which is ''-XParentProcessHandle' is not a valid parameter.' and this error is happening at step 2 in the snapshot agent job.
    As I said, it is a very simple setup, just one article and I took mostly the default settings during the setup. This has been working for me many many times except this one. The only difference is that I have just recently done a backup and restore of all SQL application and data folders on the publisher server. I was reconfiguring the server with raid 5. Before I did that, I backed up all the mentioned folders. Once I reconfigured the Raid, I reinstalled SQL 2k5 and sp2. Then restored back all the mentioned folders back to the correct path. Everything seems to be working after I restarted the SQL services. I am not sure if this replication problem is related to what I did with reconfiguraing the server. Again, the replication setup is so simple and I can't believe I run into this error. That's why it triggers me to think if restoring the folders doesn't work well in SQL 2k5 or something like that.
    Any ideas on this are very much appreciated because I am quite frustrated by this problem.
    wingman
  2. satya Moderator

    That process handle is used when referring to the server name on the distributor.
    Run select @@version and check the version of your publisher and distributor?
    Also find where about the snapshot agent is scheduled?
  3. WingSzeto Member

    Are you thinking that the distributor and publisher are on a different server? Sorry, my orginial email may not be clear enough but I did mention that the distribution db is on the publisher server so they are on the same computer. So the snapshot agent is scheduled in the same server as the publisher and distributor.
    The error is occuring when I run the snapshot agent. I thought at this step, distributor is not in use yet but I may be wrong. PLease advice.
    Wingman
  4. satya Moderator

    Ok this sounds like the capacity of data, you might check the attributes on distribution agent for
    BcpBatchSize, CommitBatchSize & CommitBatchThreshold.
  5. WingSzeto Member

    They are all default values. Are you suggesting I should increase them like doubling it? Right now, I am not even using my production db. To trouble shoot this problem, I created a test db with one table which only has two rows and two columns. This is the only table I am trying to replicate and I am still getting the error message.
  6. satya Moderator

    This problem occurs only when there is an issue with resources or mismatch of the path, so better to check both in this case.
  7. WingSzeto Member

    As far as checking the path, can you give me some idea where I should check?
  8. satya Moderator

    -DefinitionFile def_path_and_file_name
    Is the path of the agent definition file. An agent definition file contains command prompt arguments for the agent. The content of the file is parsed as an executable file. Use double quotation marks (") to specify argument values containing arbitrary characters.
    BOL states: To start the Distribution Agent, execute distrib.exe from the command prompt. For information, see Programming Replication Agent Executables.

Share This Page