SQL Server Performance

Reporting Services 2005 - Post Installation Errors

Discussion in 'SQL Server 2005 Reporting Services' started by rpallas, Mar 2, 2006.

  1. rpallas New Member

    Hello,

    I have just installed Reporting Services 2005 on a Windows 2000 server running SQL server 2000. The install went fine, although i did have to manually set up most of the configuration settings.

    - Virtual Directories
    - Service Accounts
    - Both of the databases (ReportServer and ReportServerTempDB)

    Once i had done this, i attempted to browse tohttp://localhost/Reports but i just keep getting the same error message no matter what i try to do. The error message is as follows:

    "The report server is not responding. Verify that the report server is running and can be accessed from this computer."

    I have checked that the SQL Server Reporting Services service is running, but it is still giving me the error. The service account that i have assigned it to is one that my network administrator gave me which is specifically used to run sql services on our network. I have also tried to create a new service account (ReportServer2005) on the local machine and use that one, when i do that, i am unable to start the service at all.

    Has anyone else had similar problems to this? If so, could anyone offer any advise?

    Many thanks
    Robbie




  2. satya Moderator

    Have you tried to restart IIS & Reporting services simultenously?

    Satya SKJ
    Contributing Editor & Forums Moderator
    http://www.SQL-Server-Performance.Com
    This posting is provided “AS IS” with no rights for the sake of knowledge sharing.
  3. rpallas New Member

    Thank you for replying, i am still trying to resolve this issue.

    I hadn't tried simultainiously restarting the RS Service and IIS although i have just tried it, and it had no effect.

    Forgive me for asking, but when you say simultaniously, i take it you mean at the same time? I only ask because i've not had to do anything like that before and i'm not exactly sure how simultanioulsy it would need to be done?
  4. satya Moderator

    I mean to say first stop RS and then IIS, then start IIS and RS in order.

    Satya SKJ
    Contributing Editor & Forums Moderator
    http://www.SQL-Server-Performance.Com
    This posting is provided “AS IS” with no rights for the sake of knowledge sharing.
  5. rpallas New Member

    Ahh right, that seems to make sense. I have tried that a couple of times now, but still no change.

    In the Reporting Services Configuration Manager, all the boxes in the left hand pane are ticked except the Web Service Itentity which has an 'x' next to it. i can't actually change anything on this page though as the only text box on the screen is disabled. I did a bit of reading in forums and found someone talking about a problem which sounds very similar/exactly the same http://www.sqlteam.com/forums/topic.asp?TOPIC_ID=59147#212649). The solution that was offered and accepted was to manually edit the rsreportserver.config file so that it reads in the appropriate place:

    <WebServiceAccount>IWAM_computername</WebServiceAccount>

    (but with the real computer name)

    Filled with hope, i tried this, but still...it appeared to change nothing.

    The only thing that i can think is that i might be getting confused about which service account should be being used for RS2005. As per the documentation, i created an account in the host machine called 'ReportServer2005' and i have set this account to be used in both the Reporting Services Configuration Manager and directly from the service logon settings. I have also tried using the domain account that my network manager gave me for the sql service however it was my understanding that this should be used for SQL Server and not RS (maybe i'm wrong, i don't know). On the other hand, maybe i should be using the IWAM_computername account to run the RS service, but that doesn't seem to make any sense to me. Anyway, i tried it and it didn't seem to work, so i changed it back to the ReportServer2005 account.

Share This Page