SQL Server Performance

Scheduled DTS is not picking latest data from DB

Discussion in 'SQL Server DTS-Related Questions' started by sat.offers, Apr 18, 2008.

  1. sat.offers New Member

    Hi,

    Ihave created a DTS package to export daily load to ftp folder. It hascouple of sql tasks, global variable to hold the sql result set and vbscript to read results from global variables, create files to uploadthem to ftp folder. The DTS running to success and uploading files withlatest data to ftp when I run it manually. But, when I schedule it, it’s not picking the latest data from the database. It’s uploading files with old data (the data it picked up was the data it picked when I scheduled it for the first time). I think the result set is being cached somewhere. But the ‘Turn on Cache’ property is unchecked.

    Is there any settings we have to do while scheduling the job?
    Thanks, Sat
  2. MohammedU New Member

    there is no setting in the job and I don't think it is something to the data.
    First make sure SQL Agent has the access to write to a file where the files are located. May be it is not writing and simply ftping the existing old file and not reporting the data load failed.
    Write the job output to a file and see what you get in the ouput folder.
  3. satya Moderator

    Check permissions for the login on that ftp folder & database, also better to post sample code used to see if anything we can tweak.

Share This Page