SQL Server Performance

Snapshot agent not applying snapshot if @sync_type = N'replication support only'

Discussion in 'SQL Server 2005 Replication' started by Fais, Apr 23, 2009.

  1. Fais New Member

    All~,

    Is it true that , if a subscription is created with parameter


    @sync_type = N'replication support only'
    , then even if we generate a new snapshot by restarting the snapshot agent , then snapshot will not be applied to the subscriber . Because I am facing this, I create a subscription with 'replication support only ' opion, snapshot is not being applied. But If we create a subscription with


    @sync_type = N'automatic'

    ,in this case, Snapshot agent is working cool.

    Please respond , how can I update subsciber with a fresh snapshot, if @sync_type = 'repliation support only'.

    Here is the complete script to create subscriber:


    -- Adding the transactional subscriptionsUSE [ReplTesting]EXEC sp_addsubscription @publication = N'Repltesting_mine', @subscriber = N'D2DB01', @destination_db = N'SubsTesting', @subscription_type = N'Push', @sync_type = N'replication support only', @article = N'all', @update_mode = N'read only', @subscriber_type = 0EXEC sp_addpushsubscription_agent @publication = N'Repltesting_mine', @subscriber = N'D2DB01', @subscriber_db = N'SubsTesting', @job_login = N'peoplenetsqlserver', @job_password = 'sqlserver', @subscriber_security_mode = 1, @frequency_type = 64, @frequency_interval = 1, @frequency_relative_interval = 1, @frequency_recurrence_factor = 0, @frequency_subday = 4, @frequency_subday_interval = 5, @active_start_time_of_day = 0, @active_end_time_of_day = 235959, @active_start_date = 0, @active_end_date = 0, @dts_package_location = N'Distributor'GO
  2. Luis Martin Moderator

    Kindly don´t duplicate posts.

Share This Page