SQL Server Performance

SP1 failing on cluster

Discussion in 'SQL Server 2005 Clustering' started by rklimes, Nov 24, 2006.

  1. rklimes New Member

    I am attempting to install Service pack 1 for SQL server 2005 on an active/passive cluster but it is failing while trying to patch the passive node. Below an information from "SQL9_Hotfix_KB913090.log". I have also checked the scheduled task log on the passive node with the error being "Result: The task completed with an exit code of (643)". I have been unable to find what error code 643 mean. Any help would be appriciated. Thanks.



    11/23/2006 21:58:06.969 Patching available passive node: BWBDB02
    11/23/2006 21:58:07.001 Waiting for first successfully completed passive node
    11/23/2006 21:58:07.001 Attempting to patch running passive node: BWBDB02
    11/23/2006 21:58:07.141 Successfully created remote folder for product instance target \BWBDB02
    11/23/2006 21:58:20.407 Successfully transferred payload to remote product instance target \BWBDB02
    11/23/2006 21:58:20.407 Successfully transferred payload to remote product instance target \BWBDB02
    11/23/2006 21:58:20.516 Successfully created new scheduled task for product instance target \BWBDB02
    11/23/2006 21:58:20.766 Successfully saved new scheduled task for product instance target \BWBDB02
    11/23/2006 21:58:20.766 Successfully created scheduled task for product instance target \BWBDB02
    11/23/2006 21:58:20.782 Successfully started scheduled task for product instance target \BWBDB02
    11/23/2006 21:58:20.782 Successfully started scheduled task for product instance target \BWBDB02
    11/23/2006 21:58:23.782 Scheduled task for product instance target has completed
    11/23/2006 21:58:23.782 Waiting for exit code from scheduled task for product instance target \BWBDB02
    11/23/2006 21:58:28.782 Received exit code 1603 from scheduled task for product instance target \BWBDB02
    11/23/2006 21:58:28.782 Result code for scheduled task for product instance target has been received
    11/23/2006 21:58:28.798 Removed scheduled task for product instance target \BWBDB02
    11/23/2006 21:58:29.329 Successfully removed remote folder for product instance target \BWBDB02
    11/23/2006 21:58:29.391 Remote process completed for product instance target
    11/23/2006 21:58:29.391 Exit code for passive node: BWBDB02 = 1603
    11/23/2006 21:58:32.001 The following exception occurred: No passive nodes were successfully patched Date: 11/23/2006 21:58:32.001 File: depotsqlvaultsetupmainsetupsqlsesqlsedllinstance.cpp Line: 2578


  2. rklimes New Member

    Also here is the hoptfix.log from the passive node

    11/23/2006 21:58:21.433 ================================================================================
    11/23/2006 21:58:21.433 Hotfix package launched
    11/23/2006 21:58:21.448 Successfully opened registry key: SOFTWAREMicrosoftWindowsCurrentVersion
    11/23/2006 21:58:21.448 Successfully read registry key: CommonFilesDir, string value = C:program FilesCommon Files
    11/23/2006 21:58:21.448 Successfully opened registry key: SOFTWAREMicrosoftWindowsCurrentVersion
    11/23/2006 21:58:21.448 Successfully read registry key: ProgramFilesDir, string value = C:program Files
    11/23/2006 21:58:21.448 The following exception occurred: Could not load SQLSE.rll for string localization. Date: 11/23/2006 21:58:21.448 File: control.cpp Line: 1083
    11/23/2006 21:58:21.448 The patch installation could not proceed due to unexpected errors
    11/23/2006 21:58:21.448
    11/23/2006 21:58:21.448 Product Status Summary:
    11/23/2006 21:58:21.526 Hotfix package closed
  3. satya Moderator

    If you have any anti-virus or anti-spyware programs on SQL server then stop them and again apply the hotfix.

    Satya SKJ
    Microsoft SQL Server MVP
    Contributing Editor & Forums Moderator
    http://www.SQL-Server-Performance.Com
    This posting is provided AS IS with no rights for the sake of knowledge sharing.
  4. rklimes New Member

    Do not have any anti-virus or anti-spyware software running.
  5. satya Moderator

  6. catullus Member

    SQLSE.rll is part of MDAC. What version of MDAC do you have?
  7. MohammedU New Member

    First check the version when it is on active node then...
    Try sql Failover to the passive node and apply the patch on passive node...

    Mohammed U.
  8. rklimes New Member

    The MDAC version on both nodes of the cluster is 2.82.1830.

    As for updating the active node then failing over, I dont think this is possible because in a clustered environment when you apply the service pack it will always try to update the passive node first. There are no options do active node first/only.
  9. catullus Member

    We've got a cluster over here running SQL2K5 SP1 with same MDAC version, so that's not it...
    Do you have other leads, beside the error number? Like any errors in the cluster log?
  10. MohammedU New Member

    I know there is no option to install like that but when I had an issue with installing sp4 on SQL 2000 cluster server. PSS ask me failover to the other node and reinstall the sp4 and it worked fine.

    Mohammed U.
  11. rklimes New Member

    So i have failed over to the other node an ran the SP1 upgrade from there. It installed successfully on the passive node (formerly the active) then fail when trying to update the active node (formerly the passive). The error was "unable to bring cluster service/resource offline". The sql server cluster resource was, however, brought offline. Most of the files got updated on the active node but I was unable to bring resource back online. I then proceeded to failover and was able to bring SQL server cluster resource online and it was running with a with SP1.

    Most likely there was an existing problem with the node we were having trouble installing the service pack to and have decided to rebuild it. Thanks to all for the help.
  12. MohammedU New Member

    Clean installation always better on cluster.

    Mohammed U.

Share This Page