SQL Server Performance

SP4 Install on cluster

Discussion in 'SQL Server Clustering' started by augustinius, Feb 13, 2006.

  1. augustinius New Member

    We tried to install SP4 on our main cluster this weekend. THe SP started OK, and seemed to run fine, but it reached a point where the message said, "Setup is performing required operations on cluster nodes. This may take a few minutes..." It ran for a while then the whole install window disappeared. No error code, no exit info. In the task manager, the setupsql process ran for a time then it too disappeared. This behavior was seen three straight times. Since it was so late, and since everything seemed to be working, we left it to research this morning.

    This morning, I start to inspect the situation. The binaries for SQL for that instance now show 5-05 for their dates, the version listed by SQL is Service Pack 4. The event viewer has this message: "18802: SQLSETUP: The service pack installation for HDQ-C01-N01/S1 has ended." Did the install succeed and I miss something?

    I inspected sqlsp.log and saw nothing related to an error (though this line was stating a reboot was needed, which we did not do: "01:53:00 Process Exit Code: (3010) The requested operation is successful. Changes will not be effective until the system is rebooted."
    Do I need to reboot the system soon because of this?

    I am used to seeing the window complete with a success/fail window on non-clustered boxes. Is this behavior due to the clustered environment? I can't find any help in the knowledge base so anything anyone knows would be appreciated.
  2. Argyle New Member

    You need to reboot as the the message says. It could probably not replace those files while they where active.
  3. augustinius New Member

    BUt was the lack of user interaction normal? In all other SP4 installs I have done, it gives a step-by-step of what it is doing, including scripts being run, then tells you at the end pass or fail. In this case, unless I had dug into the logs, I would be unaware of any success, or need to reboot.

    Also, are we in danger of data corruption? We won't be able to reboot until 11PM tonight. So we will have a full day of work with a "hybrid" state -- is this going to be a major problem?
  4. Argyle New Member

    A bit strange with no notification but it guess it can happen if you for example install the service pack via terminal services. The notification might have poped up on the console session and not on the terminal service user session. At least it could be that with older versions of sql server.

    It's not optimal to run with mixed files. Can't say what the impact is.

    More info here maybe:
    http://download.microsoft.com/downl...2k32sp4.htm#_installing_on_a_failover_cluster
    http://support.microsoft.com/?kbid=811168

Share This Page