SQL Server Performance

SQL Mail

Discussion in 'SQL Server DTS-Related Questions' started by pasuth, Apr 20, 2007.

  1. pasuth New Member

    Hi

    We have an absent SQL Server 2000 administrator. SQL Mail has been working fine up until a short while ago when it stopped working in Enterprise Manager DTS Package Jobs. It still works fine in QA - which also uses xp_sendmail.

    I have right-clicked SQL Mail in Support Services in EM and the current profile tests as working OK. Does anybody have any idea what I could try, or, perhaps, where I can look to edit the profile if need be? I looked in Outlook on the server as per BOL, but the profile doesn't exist there...

    Thanks

    Paul
  2. dineshasanka Moderator

  3. MohammedU New Member

    There is an issue with SQL mail in sql server 2000... if it looses connectivity with exchange due to exchange restart or network issue when it tries to send an email then it can't re-establish the connection...

    Try the following...
    1. run sp_startmail and see you send the test email using xp_sendmail...
    2. Restart the sql agent and check the jobs can send an email....

    If you two of above don't work...then restart sql services and test it again...


    MohammedU.
    Moderator
    SQL-Server-Performance.com

    All postings are provided “AS IS” with no warranties for accuracy.
  4. satya Moderator

    I believe that has been fixed in SP4.

    Satya SKJ
    Microsoft SQL Server MVP
    Writer, Contributing Editor & Moderator
    http://www.SQL-Server-Performance.Com
    This posting is provided AS IS with no rights for the sake of knowledge sharing. The greatest discovery of my generation is that a human being can alter his life by altering his attitudes of mind.
  5. MohammedU New Member

Share This Page