SQL Server Performance

SQL Server 2005 Cluster

Discussion in 'SQL Server 2005 Clustering' started by entela, Mar 10, 2007.

  1. entela New Member

    HI,

    I have a problem with SQL Server 2005 Cluster configuration.

    I change the the resources from Node A to Node B and every think looks fine.

    When I tried to run a query I got this message:

    The instance of the SQL Server Database Engine cannot obtain a LOCK resource at this time. Rerun your statement when there are fewer active users. Ask the database administrator to check the lock and memory configuration for this instance, or to check for long-running transactions.

    Can any body please help me with this.

    I saw somethink with the SQL Server Configuration Seetings, the number of locks is 5000.

    I read in the msdn but I coudn't figure out how to fix the problem

    Thanks in advance
    Entela
  2. MohammedU New Member

    I don't think it is anything to do with changing the cluster from NodeA to NodeB....
    Run the sp_lock and "exec sp_who2 active" and why sql is using so many locks....

    Kill the process which causing this problem and check the code...


    MohammedU.
    Moderator
    SQL-Server-Performance.com
  3. entela New Member

    Hi,

    Actually the problem is solved, the problem was the number of locks which was 5000. Since we updated the number of locks to 0, everythink worked fine.

    Now I have a question, How can it change the number of locks?
    Nobody has changed it by any script or anythink, and during the node changes the locks become 5000, we were really surprized about that.

    Please can you explain why that can happened?

    Thanks
    Entela
  4. MohammedU New Member

    5000 is the minimum value for the locks and I don't think it is changed during upgrade process other than some changed it manually.


    MohammedU.
    Moderator
    SQL-Server-Performance.com

Share This Page