SQL Server Performance

SQL Server Agent Could not be Start

Discussion in 'General DBA Questions' started by shekhar157, Mar 21, 2006.

  1. shekhar157 New Member

    Hi All,

    I have the problem with SQL Server Agent. When I tried to start it the error pop-up: Could not start the SQLSERVERAGENT service on local computer. The Service did not return an error. This could be an internal windows error or an internal service error". When I am looking through Event Viewer it is showing the error like:

    Type: Error Event ID: 103
    "SQLServerAgent could not be started (reason: SQLServerAgent must be able to connect to SQLServer as SysAdmin, but '(Unknown)' is not a member of the SysAdmin role). "

    All other operation on SQL Server running perfect. Please suggest me what I have to do with this problem

    Regards

    Shekhar Mishra


    "No passion in the world is equal to the passion to alter someone else's draft."

  2. Luis Martin Moderator

    You have to review the sql agent account. Check if is the same as SQL server.


    Luis Martin
    Moderator
    SQL-Server-Performance.com

    Although nature commences with reason and ends in experience it is necessary for us to do the opposite, that is to commence with experience and from this to proceed to investigate the reason.
    Leonardo Da Vinci

    Nunca esperes el reconocimiento de tus hijos, eso ocurrirá luego de tu muerte


    All postings are provided “AS IS” with no warranties for accuracy.



  3. satya Moderator

    Have you had this problem before applying SP4?
    Look in the event log to see why the service didn´t decide to start up successfully. Maybe this is a security problem or whatever,you have to check in your event log.

    Try to keep the sQLAGent in MANUAL and only when MSSQLSErver services are started try to start SQLAGent manually.

    Satya SKJ
    Contributing Editor & Forums Moderator
    http://www.SQL-Server-Performance.Com
    This posting is provided “AS IS” with no rights for the sake of knowledge sharing.
  4. shekhar157 New Member

    HI,

    Actually it was running fine with SP4. Only I change the sa Password and from change of password I am facing this problem.


    Regards

    Shekhar Mishra

    "No passion in the world is equal to the passion to alter someone else's draft."

  5. shekhar157 New Member

    Hi,

    Hey Buddies I need ur help urgent. Plz do rwply.

    Regards

    Shekhar Mishra

    "No passion in the world is equal to the passion to alter someone else's draft."

  6. ghemant Moderator

    Hi Shekhar,
    as you said you have changed SA password , now open the control panel -> Administrative Tools -> service -> open the SQLSERVERAGENT service and MSSQLSERVER service (see if it is set for LOCAL SYSTEM )
    and refer below thread :
    http://www.sql-server-performance.com/forum/topic.asp?TOPIC_ID=13469

    Hemantgiri S. Goswami
    ghemant@gmail.com
    "Humans don't have Caliber to PASS TIME , Time it self Pass or Fail Humans" - by Hemantgiri S. Goswami
  7. shekhar157 New Member

    Hi Hemant,

    I have look that link but i tried all the options mantioned in the link. When I am trying to start SLQSERVERAGENT throught services manually it is showin the error:

    "Could not start the SQLSERVERAGENT service on local computer. The Service did not return an error. This could be an internal windows error or an internal service error".

    And after it when I am checking in Event Viewer it is showing the problem:

    Type: Error Event ID: 103
    "SQLServerAgent could not be started (reason: SQLServerAgent must be able to connect to SQLServer as SysAdmin, but '(Unknown)' is not a member of the SysAdmin role). "

    My all other application running properly using SQL Server but agent could'nt be start. waiting for soon reply.

    Regards

    Shekhar Mishra

    "No passion in the world is equal to the passion to alter someone else's draft."

  8. satya Moderator

    If you have changed SA password then ensure SQL Server services account password has not be changed. It will be useful if you can apply the same using control panel -> Administrative Tools -> service -> (as explained above).

    Ensure the account used to start the SQL services has admin privileges or required privileges to start the service. The error above is self-explanatory.

    Satya SKJ
    Contributing Editor & Forums Moderator
    http://www.SQL-Server-Performance.Com
    This posting is provided “AS IS” with no rights for the sake of knowledge sharing.
  9. shekhar157 New Member

    Hi Satya,

    I hav checked in setting->control Panel->services. The Log on for SLQ Server and SQLSERVERAGENT is same as it is checked on "Local System Account". Both services using the same log on as Local System account. Please suggest me what else I can check.

    Regards

    Shekhar Mishra

    "No passion in the world is equal to the passion to alter someone else's draft."

  10. satya Moderator

    You need a local or domain account with admin or required privileges to start the SQLAgent as the scheduled jobs may fail if they require network or special access within the server. There were some changes made since SP4 installation, so you have to follow them.

    Satya SKJ
    Contributing Editor & Forums Moderator
    http://www.SQL-Server-Performance.Com
    This posting is provided “AS IS” with no rights for the sake of knowledge sharing.
  11. ghemant Moderator

    Hi Shekhar ,
    >>reason: SQLServerAgent must be able to connect to SQLServer as SysAdmin, but '(Unknown)' is not a member of the SysAdmin role
    have you or any admin rename admin account !? it seems that it doesn't identify user !

    and also look at msdb..syscachedcredentials table in test and production server .

    and a thread :
    http://www.mcse.ms/archive97-2005-6-1669961.html


    Regards

    Hemantgiri S. Goswami
    ghemant@gmail.com
    "Humans don't have Caliber to PASS TIME , Time it self Pass or Fail Humans" - by Hemantgiri S. Goswami
  12. shekhar157 New Member

    Hi Hemant,

    I have look in the syscachedcredentials(MSDB) but there is no rocord. The table is blank.

    Regards
    Shekhar Mishra

    "No passion in the world is equal to the passion to alter someone else's draft."

  13. shekhar157 New Member

    Hi All,

    Thanx for all your suggetions so I can reach to problem solution. I just made it start now coz in Enterprises Manager the SQL Server Agent properties there is connection type is Windows Authentication I just change it to SQL Server Authentication and now it running fine. Thanx again to All.

    Regards

    Shekhar Mishra

    "No passion in the world is equal to the passion to alter someone else's draft."

  14. ghemant Moderator

    Hi Shekhar,
    i appriciate your feed back, and thanks for sharing solution of problem.


    Regards

    Hemantgiri S. Goswami
    ghemant@gmail.com
    "Humans don't have Caliber to PASS TIME , Time it self Pass or Fail Humans" - by Hemantgiri S. Goswami
  15. satya Moderator

    I think a link is missing here, have you used MIXED Mode previously and if the application & SQLAgent working with WIndows authentication only then why to change it to work out.

    Satya SKJ
    Contributing Editor & Forums Moderator
    http://www.SQL-Server-Performance.Com
    This posting is provided “AS IS” with no rights for the sake of knowledge sharing.
  16. mikehdow New Member

    I had this issue after moving system databases around (http://support.microsoft.com/kb/224071).
    Turns out that I had left the T3608 startup switch on. Once I removed that switch and restarted SQL Server, SQL Agent turned on without error.

Share This Page