SQL Server Performance

SQL Server with HT - But only use one of the CPUs

Discussion in 'Performance Tuning for Hardware Configurations' started by AlexD1979, Apr 7, 2006.

  1. AlexD1979 New Member

    Hello @ll,
    It is not longer funny, i spend time and time again to find the problem, why our SQL Server only uses 1 part of the CPU.
    We have the following configuration:
    Windows Server 2003 Standard german
    SQL Server Standard 2000 with SP4 german 8.00.2039 (SP4)
    DELL Server 3,2 Ghz Xeon with HT enabled.

    We submitted some SQL Jobs and the CPU usage is overall 50-55 Percent. If i take a look at the Task Manager, the sqlserver Process takes exact 50% of CPU time.
    Why the Server don´t take all CPU time for the process?
    In the Properties of SQL Server, the Tab "Processor" shows 2 available CPUs and the Option use all available CPUs is enabled.

    On other system, similar Configuration, but Enterprise SQL Server it works.

    Can anybody take time and tell me some tipps to get more power for the SQL Process?
    BR
    Alex
  2. joechang New Member

    leave this alone
    even if you did get higher utilization across both logical proc in a single physical proc, there is not much difference in performance for SQL Server, sometimes even a loss
  3. AlexD1979 New Member

    quote:Originally posted by joechang

    leave this alone
    even if you did get higher utilization across both logical proc in a single physical proc, there is not much difference in performance for SQL Server, sometimes even a loss
    Yes normally not so important but on this server we cannot execute mass Impoting databases and Update Scripts in reason of outbreaks of the Server.
    He stopps executing after a few minutes and in the Frontend we get errors.
    On the Same Machine works a Webserver. So this processes not very load-balanced if some task blocks one complete CPU themself.

    On another Server with Normal Desktop Intel 3,4 Ghz HT CPU it works fine.
  4. joechang New Member

    you did not say that was the main issue,
    in this case, disable HT

Share This Page