SQL Server Performance

Sqlbrowser host name

Discussion in 'SQL Server 2005 Analysis Services' started by tboonleong, May 14, 2007.

  1. tboonleong Member

    When I want to browse the cube data using MS SSAS, the error show as below:

    Error in the OLE DB provider.Could not connect to the redirector.Ensures that the SQLborwser services in ruuning on 'BoonLeong' server.
    Error in the OLE DB provider.An error occur while name instances was being retrieved from sqlbrowser services on 'BoonLeong' server.

    FYI, the instances name for ms sql 2005 is 'BoonLeongSQL2005'.
    I try to coonect to Anaysis services from managemement studio with host name 'BoonLeong' then connection fail. But if using 'BoonLeongSQL2005' then connection fine and is connected well.

    For this situation,I checked the sql browser setting inside the ms server configuration manager, the host name is 'BoonLeong'.

    Question:
    Should I need to change the host name at sqlbrowser to 'BoonLeongSQL2005'?If yes,May I know how to change the host name setting?If answer is no, what is the actual issue here that I can not browser the cube at ms ssas?
    Hope to able get the answer as soon as posible.
    Thanks again .
  2. tboonleong Member

    FYI,Is confirmed that the sqlbrowser services was running during the above testing.
  3. tboonleong Member

    After checking so many things, the error still encounter. At last I restart the server and no such error encouter.
    Really funny with this situation.[xx(]
    Thanks
  4. satya Moderator

    Have you observed in event viewer about the other error such as:

    quote:
    The description for Event ID ( 22 ) in Source ( xxxxxx) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: Internal error: An unexpected exception occured.."

    I have had this error previously on the environment of SQL Analysis services, Reporting services along with usual SQL 2005, to resolve verify that the SQL Server Browser service is running and is configured to start automatically and als verify that the SQL Server Browser service is running under an account with administrator rights on the local computer—such as the local system account.



    Satya SKJ
    Microsoft SQL Server MVP
    Writer, Contributing Editor & Moderator
    http://www.SQL-Server-Performance.Com
    This posting is provided AS IS with no rights for the sake of knowledge sharing. Knowledge is of two kinds. We know a subject ourselves or we know where we can find information on it.
  5. tboonleong Member

    When I process the cube and browser the cube data again, same error come out as below:.<br /><br />Error in the OLE DB provider.Could not connect to the redirector.Ensures that the SQLborwser services in ruuning on 'BoonLeong' server.<br />Error in the OLE DB provider.An error occur while name instances was being retrieved from sqlbrowser services on 'BoonLeong' server.<br /><br />I restarted pc and browsed the cube data again, no problems at all.The error only come out after i reprocess the project.[xx(][<img src='/community/emoticons/emotion-6.gif' alt=':(' />]<br /><br />I tried to use pivot to connect to anaysis server, but connection fail.[V]<br />Hope to get you advice and opinion.Thanks.<br /><br />
  6. tboonleong Member

    I tried to uninstall and istall again the ssas , the problem still at there....[V]
  7. satya Moderator

    You could try the following:
    -Change the SQL server Browser service running Account to Local System Account
    -Create My Login Account in SQL >Security->Login
    -Double click on AdvantureWork.ds from DataSource (From Solution Explorer). and in Impersonation Information Select the Use the Service Account.



    Satya SKJ
    Microsoft SQL Server MVP
    Writer, Contributing Editor & Moderator
    http://www.SQL-Server-Performance.Com
    This posting is provided AS IS with no rights for the sake of knowledge sharing. Knowledge is of two kinds. We know a subject ourselves or we know where we can find information on it.
  8. tboonleong Member

    I had change the setting base on your advice.But I still face the same error.[V]

    Error in the OLE DB provider.Could not connect to the redirector.Ensures that the SQLborwser services in ruuning on 'BoonLeong' server.
    Error in the OLE DB provider.An error occur while name instances was being retrieved from sqlbrowser services on 'BoonLeong' server.

    When I tried to drag the measure or dimension the error msg as below show as below:[xx(]
    Error HRESULT E_FAIL has been returned from a call to a COM

    Thanks again for your help.
  9. satya Moderator

    Have you restarted the browser services after above settings?

    Satya SKJ
    Microsoft SQL Server MVP
    Writer, Contributing Editor & Moderator
    http://www.SQL-Server-Performance.Com
    This posting is provided AS IS with no rights for the sake of knowledge sharing. Knowledge is of two kinds. We know a subject ourselves or we know where we can find information on it.
  10. tboonleong Member

    yes.I had restarted the services.
  11. satya Moderator

    The last option to check is whether it is equipped with latest service packs on SSAS, SSMS and SQL related components. If no solution to the issue I would suggest to report tohttp://connect.microsoft.com for a feedback on the bug.

    Satya SKJ
    Microsoft SQL Server MVP
    Writer, Contributing Editor & Moderator
    http://www.SQL-Server-Performance.Com
    This posting is provided AS IS with no rights for the sake of knowledge sharing. Knowledge is of two kinds. We know a subject ourselves or we know where we can find information on it.
  12. tboonleong Member

    I had installed the service pack 2 and the things well done.<br />No more error occur.<br />Thanks satya.[<img src='/community/emoticons/emotion-1.gif' alt=':)' />]
  13. satya Moderator

    You are welcome and that is the reson most of the times I would ask the service pack level to confirm whether it is an issue or not, appreciate your feedback that helps others [<img src='/community/emoticons/emotion-1.gif' alt=':)' />].<br /><br /><b>Satya SKJ</b><br />Microsoft SQL Server MVP<br />Writer, Contributing Editor & Moderator<br /<a target="_blank" href=http://www.SQL-Server-Performance.Com>http://www.SQL-Server-Performance.Com</a><br /><center><font color="teal"><font size="1">This posting is provided AS IS with no rights for the sake of <i>knowledge sharing. <hr noshade size="1">Knowledge is of two kinds. We know a subject ourselves or we know where we can find information on it.</i></font id="size1"></font id="teal"></center>

Share This Page